Support for Mikrotik Metal 2SHPn

Hi all!

Has anyone had any luck with installing openwrt on the Mikrotik Metal 2SHPn yet?

I have tried following the common mikrotik instructions (https://openwrt.org/toh/mikrotik/common), and have loaded the 18.06.1 ar71xx mikrotik image (vmlinux-initramfs.elf), and this seems to run, the device holds it and doesn't attempt to reboot back to RouterOS, however there are no signs of life when doing so - nothing on the LEDs and no activity via the ethernet interface (have done a pcap and can't see any packets coming through).

(https://downloads.openwrt.org/releases/18.06.1/targets/ar71xx/mikrotik/openwrt-18.06.1-ar71xx-mikrotik-vmlinux-initramfs.elf)

Anyone made it any further than this?

Thanks

Are you trying to work on supporting this device?

I don't see this devices listed in the Table of Hardware:

https://openwrt.org/toh/start?dataflt[Brand*~]=mikrotik

I have it running (quick and dirty) with wireless and ethernet, txpower is only 17db, but I think the device has an amplifier.

I just edited:
target/linux/ar71xx/files/arch/mips/ath79/mach-rb750.c
and changed it to match the device name:

static void __init rb751_setup(void)
{
        rb750_setup();
        ath79_register_usb();
        rb751_wlan_setup();
}

MIPS_MACHINE(ATH79_MACH_RB_751, "groove-5s", "MikroTik RouterBOARD Metal2",
             rb751_setup);

second file was:
target/linux/ar71xx/patches-4.9/701-MIPS-ath79-add-routerboard-detection.patch

+           strstr(arcs_cmdline, "board=wapg-sc") ||
+           strstr(arcs_cmdline, "board=groove-5s") ||
+           strstr(arcs_cmdline, "board=2011L") ||


cpuinfo:
system type             : Atheros AR7241 rev 1
machine                 : Generic AR71XX/AR724X/AR913X based board
processor               : 0
cpu model               : MIPS 24Kc V7.4
BogoMIPS                : 265.42
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
isa                     : mips1 mips2 mips32r1 mips32r2
ASEs implemented        : mips16
shadow register sets    : 1
kscratch registers      : 0
package                 : 0
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

The Device Name is: groove-5s

[ 0.000000] Kernel command line: parts=1 boot_part_size=4194304 gpio=790343 HZ=200000000 mem=64M kmac=D4:CA:6D:9D:83:5C board=groove-5s boot=0 mlc=4 console=ttyS0,115200 rootfstype=squashfs noinitrd

Your a wizard humnab - thankyou!

Which version did you use here? I tried with the latest 18.06 and got basic ethernet and commandline, but no luci and no wireless. And then tried with the latest master and couldn't get it to boot either. Bit hard to figure out whats going on without a serial connection.

Thanks again

I used 18.06.1, I will try to send you patches against plain 18.06.1 this weekend. If I remember correctly I followed this guide https://forum.archive.openwrt.org/viewtopic.php?id=16599 to install luci an enabled it in menuconfig. I will check this this weekend also, I did my tests some weeks ago and don't know if I remember this steps correctly.

Has there been any other update on this??? There is an AMAZING software created for the groove and i think its from wrt check out wifiranger. I Need someone who could help me in creating a software like this to easily to connect and save AP locations.https://wifiranger.com/images/guides/WiFiRanger_UserManual_Rev11.pdf

I AM A NEWBIE BUT I AM VERY AMBITIOUS TO LEARN!!!

I am trying to get a firmware for the RBMetalG-52SHPacn. I am very new, Is there any one that has run firmware and was successful? There is a awesome openwrt build but it looks like its not available to the public without buying there installed openwrt groove software. i need help getting the groove working.
Thanks

This topic here is about adding OpenWrt support for this device.
Please split your request for OpenWrt firmware and wifiranger-linke software package into separate topics.

ok i will make a new topic for the ranger

How is the build for this router coming along? I don't want the wifi ranger - I just want OpenWRT.