Support for Mikrotik Hap AC2

please provide a new link for downloading the build
does wlan ac work properly ?


1 Like

I agree on 802.11n or 802.11g. Waiting news from @flipy


1 Like

Mikrotik despite having its ROS 7.1 running on top of kernel 5.6 still doesn't offers SQM as an option for end users, I hope @flipy can get WiFi working on this unit

Will work this weekend to pull the latest master branch and provide a build.

Must say that all kudos go to @robimarko and others for reverse engineering parts of the firmware implementation on Mikrotik.

1 Like

Is serial access needed to install OpenWRT on this unit?

There is quite a bit of cross chatter in this thread so I'll just reconfirm (mainly for Flipy):

As I am sure you know, the build compiles, flashes and boots just fine.

I tested the following and was working fine:

Switch + POE In + Wifi.

All worked.

The only major issue was that wifi performance was abysmal. Most likely the calibration data was not correct, but regardless of txpower setting I had to essentially sit RIGHT next to the router to connect to either 2.4 or 5.8ghz band.

EDIT : When I say "wifi performance"... I mean the signal to the client. RSSI would drop to near zero as soon as I was a few meters away. When I was right next to the router, I was able to get normal 200-250mbit transfers no problem. My usual daytime ISP RX is about 250-300mbit so it was near the top.

Would LOVE to see this unit fully supported as I own one and recentlly purchased an older RB952 since I was not able to use this. Reason being is its nice wall mounted, POE powered... Everything else is socket mounted and the 2 year old will yank it out as soon as we move the box covering it... Wall mounted + 1 ethernet cable should hold up :wink:

Big thanks again, will be keeping an eye to see fully working wifi support pop up.

That might be true.

Up until recently, calibration data stored in the ART partition couldn't be decrypted hence WiFi was not working.

Here you can get a build version pulled from master with all necessary patches for Mikrotik, I plan on testing it today to check wifi performance.
I've included LuCI thru nginx-ssl.

Serial access is not mandatory if you follow the TFTP installation guide.
Do make a backup of your RouterOS license.


Thanks for the build. Am I correct in assuming this build is also present in:

I see commits from yesterday, so guessing it is.

I feel a little more comfortable doing a build myself rather then flashing a pre-compiled blob :wink:

Making it as we speak, will flash in about 1 hour and post my results.


Same issue :frowning:

Here is a quick dump from iwinfo, I am sitting about 1 meter way from the access point @ 5.8ghz:

          Mode: Master  Channel: 36 (5.180 GHz)
          Tx-Power: 23 dBm  Link Quality: 12/70
          Signal: -98 dBm  Noise: -111 dBm
          Bit Rate: 780.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11nac
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy1

Its a shame because this device vs the RB952 (which as noted in prev post, I hope to replace with this ac2) is much more powerful, here is an iperf3 LAN to LAN:

[  5]   0.00-1.01   sec   112 MBytes   935 Mbits/sec   10    604 KBytes
[  5]   1.01-2.00   sec   112 MBytes   942 Mbits/sec    0    604 KBytes
[  5]   2.00-3.00   sec   112 MBytes   937 Mbits/sec    0    607 KBytes

Both directions TX / RX are pretty much able to saturate the 1GBIT link.

Dmesg does not show anything out of the ordinary.

Edit : Its almost as though the antenna config is incorrect? I tried remvoing my country code setting from the config, no help. iw list is showing that its usuing whaver antennas are available.

root@OpenWrt:~# iw list | grep Ant
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x3 RX 0x3
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x3 RX 0x3

Edit 2 : Noticed its using the ath10k-ct drivers + firmware... Will try using the non-ct set now. Will post once built + flashed.

Edit 3 : Every so slightly better... Still abystmal though... I can move about 2 meters away now... The link quality indicator in iwinfo did move up a tiny bit... Also without the ct firmware its caped at 20dBm both 2.4 and 5.8.

Edit 4 : Just tried forcing 2.4ghz, and the same... Signal is slightly better but still unusable.

Edit 5 : Also, noticed that proc/cpuinfo doesnt have the usual mikrotik related bits that the RB952 build does... Eg: Model #, etc.

Edit 6 : Tried flashing your precompiled binary, it won't boot now. No light dance at all so does not look like OpenWRT is starting up at all. Probably not an issue as I should be able to recover it via the tftp boot but thought I would mention it.


Just FYI, the wifi issues have nothing to do with the build per say...

Looks like the board file for the hap ac2 is missing so its using a generic one which causes the incredibly low signal.


Good thing you tested my prebuilt!
I'll dig it up and see what's going on.

As per BDF files you're right, CALDATA was missing.

There were initial efforts to try to identify how Mikrotik is accessing BDF -- that included getting a support file from ROS and using ghidra to check the wifi driver is being loaded.


Still unverified by me but looks like a few smarter-then-I folks @github have figured it out:

Should be as easy as compiling a build that boots on the hap ac2, then after its flashed run:

dd if=/sys/firmware/mikrotik/hard_config/wlan_data skip=12064 iflag=skip_bytes oflag=seek_bytes bs=3016 count=4 of=/lib/firmware/ath10k/QCA4019/hw1.0/board-2.bin seek=84 conv=notrunc
dd if=/sys/firmware/mikrotik/hard_config/wlan_data skip=44832 iflag=skip_bytes oflag=seek_bytes bs=3016 count=4 of=/lib/firmware/ath10k/QCA4019/hw1.0/board-2.bin seek=12212 conv=notrunc

And reboot.

You should at this point have proper wifi.

Like I said, still unverified.

EDIT : Compiling a build as we speak, should have it tested in about 45 minutes.


If everything goes well then this is the perfect ER-X substitute (quad-core ARM vs dual-core MIPS) for people wanting to have SQM and serious home network management in a budget, plus it has built-in WiFi which should be enough for small flats. Kudos to the devs!


I agree.

Everyones needs are different... I need something POE + that has a USB port... I tried this first, and ended up ordering an older RB962... It's fairly low powered though... Not that I NEED it... But it tends to top out at roughly 350-400mbits (over the wire), without any NAT / firewall.

When I tried this hap ac2 build (with the broken wifi), I was able to saturate my 1gbit link no problem.

Fingers crossed!


Tested and works for me.


Can you share the build you used?

here you go...


Tried your build with the above workaround, WiFi is working relatively good but there's no way to change the country code and TX power is too low. I tried using iw but it always returns 00 as country code.

Edit: 2.4ghz mac doesn't coincides with the one in stock FW but 5ghz do

WiFi feels faster than stock when close to the router but range is now lower

Edit 2: I've managed to persistently set the country code to US doing the following

uci set
uci set
uci commit wireless

Coverage is now better than stock :smiley:

Edit 3: @subixonfire can you build it with SQM package pls?

1 Like

SQM piece of cake is working flawlessly, I actually had crazy ping spikes caused by on demand governor setting it to performance fixes it.

1 Like