Support for Mikrotik Hap AC2

Thanks for the explanation :wink:

I was actually able to add the multi-cal into PR as well.
DTS is also corrected for the Routerboot partitions driver.

So feel free to build off that.
I will fix the 10/100 LED-s in the PHY PR I already have opened:


Thanks, 2.4GHz keeps the original MAC address after reboots

Build download with SQM:

1 Like

I follow below instruction to install openwrt but cannot transfer the file to Router. I use Tiny PXE

Anybody can share your experience.

Anyone can confirm Hap AC2 can use below method.

reboot the routerboard via TFTP from the RouterOS web configuration interface.

Connect a PC to a LAN port (port 2…). Log into the web interface of RouterOS and set router to boot from ethernet once with DHCP:

  1. System → Routerboard → Settings → Boot device: Try ethernet once then NAND
  2. System → Routerboard → Settings → Boot protocol: DHCP
  3. System → Routerboard → Settings → Force Backup Booter: Checked (if supported by your routerboard - !IMPORTANT)


1 Like

log in to routerOS webfig, setting those step 1, 2, 3. and then shutdown.. set ip static..put your ethernet cable on port 1, power it on then open tiny pxe, pick the initframs.elf image and press online.. remember disable virtual port ethernet, wifi etc except port you use it.. after sending succes.. disable port ether, klik tiny pxe offline, set ip otomatic and then plug in to port 2.. login and flash sysupgrade
i use tiny pxe from this tutorial for debrick..Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion

Can you tell me how to boot router in TFTP mode ? I have a litter bit confuse.

The easiest it's to start the PXE server with the ELF selected, change RouterBoard settings to try ethernet then flash, connect your PC to WAN port, reboot the router and then check the PXE screen it should say IP assigned transferred file.

Wait some seconds after that and then connect to a LAN port, the webgui should be available at and do the sysupgrade.

I have added LED configuration to the PHY driver via DTS.
That has been pushed to the PHY PR as well as this PR, so LED-s now work on 10/100/1000 speeds instead of just gigabit.

1 Like

worked, thanks

1 Like

I'm glad to help :smiley:

I tried your build and my 500/500 internet connection got capped at 350/350 max with software flow offload enabled. Down to 200/200 with offload disabled.

Looks like I can't replace ROS with this just yet.

Thanks you for everyone who work on this target!

Network > Firewall > and activate Software flow offloading (you can play with Hardware flow offloading too)

Do you use PPPoE or QoS?

PPPoE on the WAN side.
No QOS rule.

OpenWrt doesn't supports PPPoE hardware acceleration like ROS do

Hello robimarko. Are you planning to add DSA support for hAP AC2? Do You know how things are generally going with the development of a new Ethernet driver to replace essedma?

1 Like

Yeah, DSA is WIP but nobody has been able to get it to work reliably.
IPQ40xx would really benefit from it, its the ideal candidate as it only has one CPU port.

But due to how they hacked a external QCA8337N switch into the SoC and mapped it as MMIO instead of MDIO device plus the fact that it does not have its own PHY-s but uses external PHY-s with PSGMII its rather hard to get it working.

They way that ethernet, DSA and PHY drivers designed is to have everything separated and calling standard functions while this mess requires DSA to read/write to the PHY-s directly etc.

So, its being worked on but its really buggy currently.

1 Like

use lan

I use 1G internet.


Is that with software offloading disabled?