Support for Linksys E2500 V4

Link says serial port...

Hey @j-d-r ,
Thanks for your work on this! I have a couple of E2500s that I picked up on clearance. I was able to tftp the new version, but the 5GHz radio does not show up in config. I will try the older release to see if that works, but I wanted to let you know about the latest one. I'll be happy to test or build images now that you laid the groundwork.

I actually want to use my routers for 2.4GHz only, so that's not an issue for me, but it will be for average users, if they want to get the AC1200 speeds at the price of a 600 :wink:

The March 30 release does show the 5GHz radio. I will keep playing with that one for a while to report use.

Thanks again for your work! @j-d-r

I kept the March 30 release and was able configure without issues. I added a couple of luci pages, removed some packages, and added a custom ssl cert. It works great. I have had it running for a few days and it is very stable, no dropped connections, plus I am getting 150 Mbps on 2.4GHz and 867Mbps on 5GHz. That is the performance of the e5400!! I need 20MHz channels for legacy and IoT stuff on 2.4, or I could get the 300 Mbps. Still, it's awesome. Thank you!

Great to hear. It's very stable on my E5400 too.

It's strange that 22.03 does not show radio, 2500v4 and e5400 are supposed to be the same boards ( and it works on mine. Was the radio listed on wireless tab, or was it just disabled due to unsupported configuration? Installing wpad-wolfssl may solve the problem.

btw, I'm testing changes/cleanup on Device Tree and I will receive soon a E5350 (same hardware) to test. I will release soon a new test version.

1 Like

Both mega links have expired. Is it possible to re-upload the serial pinout photo and OEM flash dump?

The place to collect valuable information like serial pinout, how to open the case, current support status etc. would be the OpenWrt wiki.
Currently there is no devicepage for this device.

If someone wants to create a devicepage:

In case you do not already have an OpenWrt wiki account:
Applying for OpenWrt wiki account

Your support is appreciated! :slight_smile:

Hi @tmomas,

Thanks for the info. I went ahead and created a new device page with links to this discussion and @j-d-r's github repo. The page is here
I wasn't sure what to put under supported, so I chose Not supported, since these are experimental, externally created images.

Now, would these efforts bring the V4 closer to being supported, or are we out of luck because it uses a MediaTek CPU?

1 Like

The serial pinout is in the device page I created. You only need Gnd,Tx, and Rx.

Before I flashed one of my devices, I used OpenWRT's memory dump to get copies of all partitions. I'll see if there is a spot to upload that to the device page or the tech page.

Hi, I've published two releases for testing:

I cleaned the DT:

  • removed polling for GPIO, it works without
  • renamed led system led is written WPS
  • renamed pinctrl0/gpio/ralink,group to pinctrl0/gpio/group (previous name was ignored by kernel, and issue a warning for not found DT value)
  • use the two MAC address in flash (config+0x22 and config+0x28)
  • cleanups

I tested them with on a E5350 and a E5400, everything seems ok.

1 Like

You da man, @j-d-r !!

Thank you for your work on this. I'm really happy with how solid my e2500 is.

I have a "dev" unit I picked up for tests. I'll load the new versions this weekend and report after a few days.

As everything seems OK, I issued a PR

Hi, I'm wondering if any of the above users can comment after a period of prolonged use on whether you have encountered any issues or limitations whatsoever with these builds on an e2500v4.

Thank you!

Not sure if this is an acceptable use of this forum, but - as an end user too dumb to install - would love to see this progress & also to use this build if it can be made available for end users prior to completion of the pull request. Doesn't sound like an official release will incorporate this work anytime soon.

Request guidance for an end-user installation. (Using e2500 v4.)

PR is merged in master.

1 Like

An old bloke needs a bit of assistance to install openwrt on Linksys E2500v4. Some experience with linux, can anyone here give me some pointers?
Merci beaucoup!

You won't need Linux, but a 3.3v USB TTL cable.

It seems that this router has the same hardware as E5400. There is a firmware flash for this ending in kernel.bin.
I have tried following the directions to use tftp64 server but no joy, i set the ethernet to and tried to transfer the .bin file which had been renamed and copied to the ttftp directory.

Linksys (Belkin) E2500v4 (N600), E5300 (AC750), E5350 (AC1000) and E5400 (AC1200) share the same hardware. They are all supported since commit b893aa79 in version 23.05 to be released, rc1 is available.

Required materials:

Installation instructions:

  1. Connect to UART, use LF as EOL (not CRLF)
  2. Set IP address:
    • Press 4 during boot
    • setenv serverip <TFTPSERVER_IP>
    • setenv ipaddr <DEVICE_IP>
    • setenv bootfile openwrt-23.05.0-rc1-ramips-mt76x8-linksys_e5400-initramfs-kernel.bin
    • saveenv
    • reset
  3. Load Openwrt Kernel image from TFTP:
    • Press 1 during boot
    • IP and filename should be already set
  4. Boot into OpenWrt and perform sysupgrade with sysupgrade image.

Where can I get device and server ip? I'm assuming routing functionalities dont work if boot is interrupted, does that mean I need to connect the TFTP server with the E5400 on another routers network?