Support for Easybox 904 LTE that should at least give you a general idea - for ADSL you need to set annex b or j as needed, vlan tagging might or may not be required (depending on the local infrastructure).

In case of VDSL, you may need to ensure using a vectoring enabled firmware, if required by the local infrastructure.

These questions would be lantiq specific, but shouldn't be specific to the individual device (the Easybox 904 in this case) - as long as the hardware supports annex B.

Yes, for ASDL at Vodafone Germany it has to be set to Annex B.
I looked at the log file, fortunately I had switched on logging before. There is the warning again and again:

Tue Sep 25 20:24:23 2018 daemon.warn pppd[4565]: Timeout waiting for PADO packets

I had tried many settings, the service employee was not sure whether Annex J or B and whether ADSL or VDSL. It was then ADSL and Annex B. However, the connection was not established.
My second Easybox 904xDSL (with original firmware) manages to establish the connection. Even if it takes some time.
Is it possible to extend the waiting time for the program ppp somewhere?
Greetings Mike

Translated with
Ja, für ASDL bei Vodafone Deutschland muß es auf Annex B eingestellt werden.
Ich habe mir die Logdatei angesehen, zum Glück hatte ich vorher das loggen eingeschaltet. Da kommt immer wieder die Warnung:
Tue Sep 25 20:24:23 2018 daemon.warn pppd[4565]: Timeout waiting for PADO packets
Ich hatte viele Einstellungen durchprobiert, der Sevicemitarbeiter war sich nicht sicher, ob Annex J oder B und ob ADSL oder VDSL. Es war dann ADSL und Annex B. Jedoch kam die Verbindung nicht zustande.
Meine zweite Easybox 904xDSL (mit Original-Firmware) schafft es jedoch die Verbindung aufzubauen. Auch wenn es etwas dauert.
Kann man die Wartezeit für das Programm ppp irgendwo verlängern?

Gruß Mike

Hey everybody!

I just recently got my hands on a used '904 xDSL, and everything went flawlessly (installing OpenWRT snapshot via TFTP recover, then flashing the new boot animation) until I tried to use the 904 behind a cable modem to connect to the internet.

The cable modem has a LAN-port, then I tried to connect it to the WAN-port of the 904.
The serial console logged

lentiq,xrx200-net 1e108000.eth eth0: port 4 got link

But the device does not "see" this change in the webinterface (it still displays DSL: Line State: DOWN), I do not know enough about OpenWRT to change the interface type to DHCP client (if that is at all possible).

Then, there is a second question: In the webinterface there is the point "asterisk", for the voip server configuration (correct?).
Is there a tutorial or guide available what to set/change to use an VoIP provider (like sipgate) on the analog plugs (if that is possible)?

Your help would be much appreciated!

VLANs on the Easybox 904 is a bit tricky, as there are two switches involved, combined with the RaLink iNIC wlan that's hardcoded via VLANs themselves - you'll need to read through the old threads for the details.

Yes, you can configure the analogue FXS ports via chan_lantiq and asterisk.

Okay, the first part i figured out:
the "WAN"-port on the XRX200 switch is connected to VLAN-ID 2.
So I simply created a new interface (via webinterface) with protocol "DHCP client" and under "Physical settings" the "Interface" to "eth0.2", and it worked! Then just added this interface to the firewall-zone "wan", and the device and clients had internet!

Where I am currently struggling with is asterisk: the asterisk package itself is not installed (and not installable), but the luci-asterisk package is installed? This seems rather strange.

Btw: I am using the snapshot version 01.10.2018 (or 2018-10-01); r8233-5edb6314f

Another "small" problem: if I try to install a kernel module via opkg, the install fails as the packages expect the kernel version to be different (4.14.74-something) vs the installed kernel 4.14.72, is there any solution to this? Self building?

And please be kind, my technical understanding of OpenWRT is - at most - basic.


You might have to build the firmware image from source, to get compatible kernel modules.

Thanks to Quallenauge and the Openwrt developing team to add the modified rtl-8367b switch to openwrt.
And i see that the kernelconfig are the same now.
What speaks against it too add whole device to Openwrt ?

Anyway, i have create a patch for openwrt master (it was working on 14.10.2018) to add this device.

I have build an full working (with telephon) openwrt image and the reposatory from 14.10.2018.
It contain the patch and the buildscript for the patch
The reposatory must be on an USB stick see repo_root
base-commit.txt is the commit of used openwrt the used commits of the packages are inside feed.conf
I use use 5 steps to build it:

  • download of all packages and the feed.config with the right commits
  • build openwrt from source
  • build the easybox and own packages via SDK
  • creating an reposatory by overcopy the new one to the old and making an index on SDK via "make index"
  • making an image via imagebuilder
    for this reason is the where i have fixing some problems at SDK build especially for the FBTFT driver.
    for streaming experiments with the screen i have build this:

note: wireless does not work out of the box, i add an config example in the "config" directory

Booting from USB by changing the commandline like the lines in dts files, does not work.
I thing the reason is the kernelconfig: no f2fs and no usb-storage, know erveryone the exact kernelconfig parameter ?
Exist other reasons ?

My second usb-slot does not work but i fear it is an elektrical problem or have everyone the same problem ?

Hmm i have this strange error on starting asterisk:

root@OpenWrt:/# [  194.438890] [/mnt/mapper/sda3/build/owrt/build_dir/target-mips_24kc_musl/linux-lantiq_xrx200/drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_ar9.c ifx_mps_download_firmware 140]: warning, image does not contain size - assuming 1MB!
[  197.671902] [/mnt/mapper/sda3/build/owrt/build_dir/target-mips_24kc_musl/linux-lantiq_xrx200/drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_ar9.c ifx_mps_release 380]: Timeout waiting for firmware ready.
[  197.763118] MPS: FW checksum OK
[  197.764969] 00000008: 86b75ca1
[  197.768099] 0000000c: 86b75ca1
[  197.771158] 00000010: 86b75ca1
[  197.774363] 00000014: 86b75ca1
[  197.777496] 00000018: 86b75ca1
[  197.780636] 0000001c: 86b75ca1
[  197.783692] 00000020: 86b75ca1
[  201.383919] [/mnt/mapper/sda3/build/owrt/build_dir/target-mips_24kc_musl/linux-lantiq_xrx200/drv_vmmc-1.9.0/src/mps/drv_mps_vmmc_common.c ifx_mps_get_fw_version 3114]: timeout
[  201.398257] IFX_MPS: firmware download error (-14)!

It was working well on 25.09.2018
I fix it with overcopy with the same firmware from kmod-ltq-vmmc package.
I think it is a right mananment error on the FS or somthing else.

1 Like

Hi, tried your add-eb904x-support-for-master-2018.09.20.patch . Looks good. Great!

Only I think that including file /etc/uci-defaults/80_wifi_setup might be good idea.

This script is run once during overlay initialization, and then it is removed. It is responsible for initializing /etc/config/network with reasonable values for VLANs and switches specific to the eb904.

Thanks i forget some simicolons in my script here is an update but i have not tested yet:
(patch and buildscript inside tar.gz)

Ha! From your post I eventually learnt the meaning of "WAN" port on the Switch screen
for the " Lantiq XRX200 Switch" in the eb904: The jack labelled "DSL" is actually a combined DSL/ethernet connector.

But it seems to be 100 Mbits only. In case this limts your cable speed, you might prefer to connect it to a yellow jack and adjust your switch settings to isolate it from your LAN.

Referring to Asterisk: the last time I looked, the Luci Asterisk package was of no use.
So on my HomeHub, I installed Asterisk15 (with chan_sip, not pjsip) and adjusted the files in /etc/asterisk/ manually.

Referring to USB: yes, the slot intended for mobile internet sticks does not work either here at the moment.

Hi everyone,

I have locally established a git repo from openwrt master, applied Plonk23's patches, and changed some eb904 related stuff with good results, i.e.

  • added the led-gpio change of Henning Schild's pull request
  • added 2nd USB
  • changed the "sub page size" used by UBI from 2048 to the standard auto driver detected value 512.
  • reworked final stage of image build: got rid of image/; little additions in image/Makefile suffice for building sysupgrade, fullimage (=recovery image), initramfs.

The question is now: how to continue? I see Quallenauge's repo, Plonk34's patches, the images provided by Hans Müller. Probably there is more to find...

First thought is to take Quallenauge's repo as a reference and push changes towards him. But isn't this repo many commits behind OpenWrt master? Is Q'auge maintaining it? A statement from him would be helpfull.

Or does Plonk34 or someone else volontier to publish a repo which follows the OpenWrt master branch? Anyway, if it makes sense, I also could create a branch on GitHub hoping it is helpfull to others.

Or maybe I misunderstand the way how to develop open source stuff with the help of Git?

Thanks in advance for suggestions!

At me I assumed that my 2nd USB port has a hardware defect.
Or is there somthing missed ?
When everybody have installed my image does the second USB device working ?

It is possible to see your changes ?
I m very interreted.

In my opinion it should add to the master openwrt, i can not see any reason why not.

How does it work, my problem are I'm just learning to deal with git

How can i use the Touchpad in combination with the LCD screen ?
I want to have an menü with buttons and choices.
Have everbody an example ?

gst-launch-1.0 -v filesrc location=hst_1.mpg ! decodebin ! videoconvert ! fbdevsink

RESULT: an yellow white screen with low image quality, but the video works

but H.264 videos does not work.
Have everybody an idea how i can figure out what the LCD can do ?

My stuff is not in the good shape as the one published by Qauge. It rather is in an experimental stage. Incented by your ZIP file, I looked through the changes which Qauge did and applied most of his patched: I omitted the ones which I am not convinced if they are reasonable. But considering the good work Qauge and others did, I think there might be good reasons for these patches and so I don't want to advertise my omissions right now.

Referring to the 2nd USB port: in file target/linux/lantiq/files-4.14/arch/mips/boot/dts, there is a section about usb_phy0. Simple add the same for usb_phy1, so it looks like this:

&usb_phy0 {
    status = "okay";

&usb_phy1 {
    status = "okay";

and rebuild. I claim that this works for me (but I only made a short test).
So if you have time and feel like it, then try it out and report your results here.

1 Like

How to hack with U-Boot on Easybox 904 without danger to brick it...
(and maybe this is valid too for other Lantiq devices)

Hi everyone

I fiddled around with the U-Boot and it seems it is quite possible to test a new version by loading it in RAM without flashing. See here for a description:

OK i add:

&usb_phy1 {
    status = "okay";

&usb1 {
    status = "okay";
    vbus-supply = <&usb_vbus>;

Thanks for Help

I do so: added the led-gpio change of Henning Schild's too
But what should be the result ?

I replace BLOCKSIZE=.. SUBPAGESIZE=.. etc by $(Device/NAND)
And it looks good. what was the reason for the old.

This will be interresting.

So ihave build again, but on Raspberry Pi 3 (it is slow but it does not block my only Laptop)
Here my build into two parts it may copy together:

SHA256: 98711a08e62a9490e9d81817c0d56d2ab341268ae6fd9b61b626b69d47c85243

SHA256: c3bf9908c5ec158929cdfabac809134ce773dd97ecc4ced941af9e5818f414fe

The buildscripts are are optimized for Raspberry Pi 3 and they are ugly, but i publish them here including the script for building the patches.
I hope this helps.
SHA256: 055caa5e4608bb9103d2d8bd074c72c281c4166259fe153d46779b72b5319ffa

Hi all! I added driver for 74hc595 gpio extender and changed little bit driver for touch keypad. I already created PRs in @QAuge 's repositories, but changes can be easily applied on @arnysch repo.
Hope this is one more step to complete support for this router.

I have one remark about questions and answers:

Q: AFAIK the 128MB RAM of the Easybox 904 is mapped in the address range 0x80000000-0x87FFFFFF.
So why can the U-Boot be loaded and started at 0xA0400000?

A: According to there also is:
2M x 4banks x 16bits SDRAM, 166MHz/CL3 : Winbond W9812G6JH-6, markings "Winbond W9812G6JH-6 1311W 624607500ZX" (datasheet)"
So there might be an additional RAM of size 4MB mapped to 0xA0400000-A07FFFFF?

IMHO this Winbond memory is used by Ralink rt3883 WiFi SoC. At least on PCB it placed close to WiFi SoC and traces are routed in direction to it.
Could it be some mapping magic?

1 Like

Hi, could someone conclude what's working atm and not and maybe provide a ready to Flash image via TFTP or luci?

I have an older version and unfortunately no working phone or dial in PPP...

The modem syncs, but no dial in possible. I wanna use the built-in modem and not an external one with eth0.2 configuration for DSL-port (if I understood it correctly)...


older Version from what ?

LTE (I can't say something) or xDSL variant ?
xDSL: It should work if your modem syncs but it is an generell configuration Problem please post in an new Thread
"Modem connection on Easybox 904xDSL does not work" etc

  • which Openwrt Version
  • Please descripe your connection that shoult bee. (adsl2+ annex B / PPPoE etc.)
  • post the output from "/etc/init.d/dsl_control status"
  • post your /etc/config/network (but without passwords)
  • What is exactly your problem (as i understand the Modem syncs fine, but the PPP-whatever connection does not work ?)