Support for DIR-878

Thanks a lot, that worked!

Hi guys, first time here!

Does anyone notice high ping spikes in with the snapshot version? I first notice it while online gaming, it's random but usually every five minutes I started to lag/teleport for two seconds and goes back to normal.

I tried to ping or to use mtr to address like and it stays good for most time but it has spikes registering 2000+ ms, or package loss. It's usually very fast and takes minutes to happen again.

I don't have this issue with the original firmware, or with other TP-Link/OpenWrt device I have here. Also tested with different cables, on Wi-Fi and other PCs/notebooks and it's the same. The problem seems to be in the DIR-878 with OpenWrt.

I made lots of tests in my main PC with cable connection, tried to tweak many configurations like SQM, QoS, port fowarding etc. Tried fresh installs, or to change CPU governor to performance... nothing seems to solve the problem. I don't have advance knowledge to investigate further. I do check if the router CPU usage was normal during the spikes, and it was ok, not major CPU usage and ping spikes happened at the same time.

Anyone experiencing something similar?

I have been running my own patched OpenWRT from way back when, and in particular on the DIR-878 since sometime in May 2020. Everything has been pretty stable, but with the very rare unexpected reboot (weekly?).

I am tempted to try the current Snapshot builds, but was wondering if anyone has tried the recent builds? Care to share your experiences?

@Borromini ? Saw you mention this device recently, leading me to hope you're still working with it...

I ask because I don't have the sources for my custom build, and I'm almost scared of ruining a good thing!

backup it's firmware partition & you can restore it later if you need to

I haven't seen a reboot myself, neither on 19.07 or on recent master builds (been running the latter for quite a few weeks).

No reboot here but issues with recent builds (I haven't tried pre-built snapshots) as mentioned in other topics.
Only issue that I still have is random disconnections from my Android phone. Doesn't happen on any other devices I have...

Hello guys Im new here, I bought this guy DIR-878 and tried like they described the recovery mode method when I press reset and upload the snapshot image but nothing happened can you help please, thanx a lot

Did you use the instructions at the following: Tutorial?

1 Like

need more info then Nothing Happened
did you get left with the dlink firmware ?
did it say it was flashing the device etc ?

1 Like

I read the Tutorial and switched from Chrome to Internet explorer and I managed to upgrade and got the message upgrade successfully!, thats good , but now I cant enter my router settings I tried both IPs and and both did not work I restarted the router and PC same thing what should I do bro thanx

snapshots don't come with luci
so if you are trying to a browser it won't work yet
you need to install luci via SSH

1 Like

So what do you suggest and how can I get the upgrade that comes with Luci, Im sorry im so bad and it is so complicated

support for this device is only prepared for the next real release
you will have to wait mounts for a version with luci
or you can download putty & ssh into your router & install it
however snapshots are really only beta version

1 Like

I did what this guy say

and I got a message:
unknown package 'luci'

did you have the wan plugged into the internet
& did you opkg update 1st

yes I have internet and I can browse youtube and everything and I did the first opkg update I get this message when I type opkg install luci 22222222222222

the repeated "Failed to download" says it all
do you have another internet router that you pc is using now ?
if so plug a cable from the wan port on the 878 to a lan port on your current router
& try again

1 Like

I have my 878 wan port connected to Tenda AC1200 modem router lan port, thats how I get internet to this 878 router

well until you get it to not fail to download you can't download and install luci

1 Like

I really dont understand why it wont install when I have internet and I can browse and download anything