Support for DIR-878

I updated to current master
the problems I was having with my Intel 7260 WIFI card seem to have been fixed at some point
seems to work a lot better in the 1hr of playing around I have done "80Mhz mode"
time will tell

1 Like

Hi Lucky1,

What about your Pull Request into Master branch of OpenWRT? Don't you want to include your code in it? :scream:

Hi gau

the only thing I have done is make openwrt work in the DIR-878
witch is make the DTS file & setup the basic firmware format
the MT7615 Driver is way out of my league
there was an update last week witch fixes the startup problem tho
I have made a few attempts at pull request but it's git that I have problems with
my main thing was to share what I have done so some else will have an easy start
I'm more then happy for someone else to take what I have done & finish / fix it tho
I think it wold be better from someone with an DIR-882 to sort out the USB side
witch I can't due to most of the parts not loaded on the PCB
here is a better link to my current code I updated the old one as well

I have been trying to flash both my own build and yours through the bootloader's web interface (my DIR-860L works similarly), but when I click 'upload' after selecting the OpenWrt factory image, it will just sit there for a few minutes and then show a timeout on the web page ( I thought maybe the bootloader wasn't too happy with my image being larger (it has a few extra bells and whistles), but since it also happens with your image, it doesn't seem to be the case.

The router will just sit there with the system LED blinking untill I power it off; it doesn't reboot or anything. Rebooting just brings back the official D-Link web interface.

Edit: I just renamed the OpenWrt factory image similar to the D-Link image (DIR_878_FW120B05.BIN) and the timeout happens a lot more quickly now...

Any idea what's going wrong here?

sounds like maybe it's your browser
I have had this & seem this with other routers where I have had to use IE or once only IE on windows XP
I have all ways used Firefox on windows 7 for the DIR-878
it has all ways just worked
I have had no need to test others
what browser / OS are you trying with ?

1 Like

Firefox 71.0 on Debian 10. Will boot into Windows and see if that changes anything.

Edit: believe it or not, Firefox and Chromium on Linux just timed out on me, old Edge (not the Chrome-based one) on Windows 10 accepts the factory image and is now showing an upgrade progress bar. Go figure.

Edit 2: I gave Firefox on Windows 10 a shot as well a day later because I can't seem to switch from the master image to my hackish 19.07 image, and Firefox on Windows worked fine the first time here as well. Really wonder what's up with that...

@Lucky1 thanks for your help, will be test driving the DIR-878 in the coming weeks and report back. For what it's worth, I have built an image off today's master and bumped the mt76 version and a few extra LED patches for MT7615E (among which one that Lucky1's PR points to). First of course you'll need his pull request for DIR-878 A1 support.

Patches I added:

The last patch just pulls in present mt76 master (has seen a few MT7615E related commits since the previous 2019-10-10 version).

For those wanting to build themselves, just grab them and apply with git am, then pick the DIR-878 from the supported targets and run a build.

I would expect a difference between browser type like IE,Edge Firefox
but i would think Firefox on linux would work the same on windows
I'm surprised it's different

So am I. I thought maybe the firewall was at play, but even with that disabled, it didn't work. I reflashed a DIR-860L this way yesterday, and that went just fine from Firefox, the same Linux setup. Weird stuff.

Opened the router, to see the possibility of adding a USB port...
Well, guess it's possible, the pcb has all the traces, but obviously, missing the smd parts..
Anyone actually tried it?

@Lucky1 Did you resolder the serial header on yours? I just opened mine up after my first serial 'experience' in a long time on the DIR-860L rev B1. Was a bit disappointed to see what I presume to be the serial headers just filled with solder...

The header is neatly populated on the FCC pictures...

That's often the case, probably because they're certifying pre-release devices. But see the bright side, that's also a strong indicator where the serial console is hiding. Ideally you use a little solder wick and a solder sucking pump, to clean up the connection, so you can pass through your pins and solder them in.

1 Like

Thanks, but trying serial was already quite the learning process (well at least I knew TX and RX went the other way around...). I have zero soldering experience nor do I know people who could do that. So I'll just be patient for a bit until the support gets merged :slight_smile: .

1 Like

if you are doing basic stuff you can just top solder some strands of wire I often use solid cat5 that I have ling around just make I a bit longer
if you have a usb cable powered off the usb port then you don't use the +VCC "+5 or +3.3" volt pin with out this there is not much can go wrong with the 3 wires even if you put the in the wrong spots
just tape off the +vcc pin
I did this at the start but after I have to get to the SPI flash chip so I had to remove the PCB anyway so i put a header in then
I didn't want to remove the glue holding the antennas on but had to in the end

1 Like

I didn't expect the pull request to be sitting there for 6 mouths
it i would have like it to be merged so others could have added there bits like for the dir-882 etc
truth is I'm kinda over it now
I want to some how contribute but won't bother next time


Asked on IRC :slight_smile: Review picked up again!

1 Like

Just got a new DIR-878 here, setting up a build environment and happy to test!

1 Like

@Lucky1 Would you mind sharing your diffconfig? I have been trying multiple of my own builds (with UCI presets, without, default settings, ...) and they all seem to boot but no connectivity. Device has no serial pins either so I can't hook up a cable to see what's going on.

Just gave your build from April 28th a shot and that one works fine.

Thank you!

I had to look at what diffconfig was
but after running scripts/ >mydiffconfig
I get

if you can send me a firmware file i'll have a look at it's serial output

1 Like

Thanks man. I have two images here:

  • One with a modified .config (my default config - a multi-device one that also builds RT-AC57U and DIR-860L A1 images; works fine on the latter, former untested);
  • One based on a vanilla single-device config (remove .config, run make menuconfig, select DIR-878 A1, build image).