Support for Archer c50 v4

You will need to write the OEM flash backup directly to flash.

@wulfy23 would it be possible to guide me through the steps please. I run out of idea right now on how to flash OEM backup directly to flash. Whenever I try to reset the router, the network ports cuts off and then that's it. I cannot connect the TFTP.

Snapshots are nightly. You need to run the opkg install command the same day you downloaded the snapshot image.

@trendy could you help me on this issue please?

No idea how to write directly to flash, sorry.

Hi.
If You want to install a OEM firmware.

1.Download the Original firmware from Tp-link
2.Download the XVI32 from http://www.chmaas.handshake.de/delphi/freeware/xvi32/xvi32.htm
3.Open OEM firmware in XVI32
4.Select - edit - block (n) chars...
5. Select option hexadecimal and write $20200 - OK
6. Select - edit - block delete
7.Select - file - save as - "name do You want".bin , example: tplink.bin
8. Open Luci GUI on 192.168.1.1 and flash that image "tplink.bin" on New flash option.
9. Wait for reboot and into the router on 192.168.0.1

@Tibit, i tried the procedures above but it seems i can't find my router IP address. reset buttons doesn't work at all anymore. the only thing that works on my router is to connect it to another router and it works like a switch. too bad.

Check if You have access with Putty.
https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html
Only connect the Lan cable in Lan 1 port and open Putty, write in Host name "192.168.1.1" port "22" and connection type "SSH", select open and now select Yes.
Then the program open a terminal windows, where it says user, You write "root" and press enter.
If You have this acces, You´ll say me It.

Check if You turn off the router and turn it on while pressing and holding the reset button until the router has power led on and the WPS led on, then stop holding the reset button.
Then the power led and WPS led on about 8 seconds.
If this works You have access by tftp and this is good signal.

@Tibit, i surrendered after trying my luck a couple of times. 3 days have passed and i can't make it work. decided to claim a warranty from the store and i was lucky! the store replaced my bricked archer c50 v4 :slight_smile:

I'm going to wait for the final released of openwrt for my unit coz i don't want to brick it again anymore.:slight_smile:

hi everyone,

I'm back again with my newly acquired archer c50 v4. I've flash it with a working image from "Niklas Theis" website. "https://niklas.theis-web.eu/2018/12/12/openwrt-on-archer-c50v4/" they have a working image on their site but my problem right now is.

I've accessed SSH only once after the installation process. I've set all the packages including LuCi however it refuses me to connect to the router.

by the way, the router is working well with the initial openwrt installation but I can't access the web GUI and also ssh connection "Network error: Connection refused".

Is there any other way to access the web GUI or even in ssh so that i can continue downloading the packages?

I flashed the freshly compiled build on my c50 v4. I think I managed to brick it, all the lights are flashing with one of them periodically glowing red. I tried resetting the modem, when I press the reset button, the lights do go out except the power button and wifi light( or the lock symbol) and my computer detects a device on it's ethernet but then it goes back to blinking :confused:

i got mine working now. yuhuuuu!!!

different approach using "Niklas Theis" images..

i will post here tomorrow the steps on how did it worked for my (archer c50 v4 eu) on a totally different approach guys without using the web GUI when upgrading it. it's too easy... :slight_smile:

Waiting for your steps to get mine running. I still haven't managed to fix my c50 yet though. What can I do about that?

@abhinavg1997,

First of all, if you're still using the the factory firmware for TP-LINK archer c50 v4 then you're gonna be lucky.
Please visit the site below;

  1. Please continue reading and download the file being mentioned on line number 2.
  2. download this file that you will come across while reading,

SelfMade-Archer_C50v4-OpenWrt-blocktrron_c50v4-noboot

  1. To unzip it, use 7z tool so extract the image.
  2. Change the filename to firmware.bin
  3. Access your router stock router IP address 192.168.0.1 and flash firmware upgrade.
  4. Restart router and it should be working fine. try to ping the router 192.168.1.1 and it should give you connectivity. You will noticed that you will not be able to use the web GUI or LuCi after flashing it. Don't worry about that because it's going to be fixed after the sysupgrade.
  5. This time, download the file for the sysupgrade below;

https://niklas.theis-web.eu/2019/02/13/openwrt-firmware-for-archer-c50-v4/

scroll down and look for "2019.04.25 – with LuCi".
8. unzip it using 7z, then rename the file to sysupgrade.bin
9. this time, we need to use the failsafe method in order for you to do sysgrade without using web GUI or LuCi while it is not available yet.
10. download Putty
11. Host Name 192.168.1.1 Port:22 Connection type: SSH click OPEN then set the password
12. after setting up the password you need to type the following updates below;
opkg update
opkg list-upgradable
opkg upgrade opkg
opkg install luci
pkg list-upgraable | cut -f 1 -d ' ' | xargs opkg upgrade
13. When you're done typing those sysupdate list try not to disconnect yet,
14.Instead, download the file being mention below WinSCP. just find it in google
15. Whenever you're ready, use the tool and login.
File Protocol: SCP
Host Name: 192.168.1.1
Port#: 22
User Name: root
Password: create your own password
16. Try to connect with WinSCP while your connected with PUTTY. If you are successful on logging it, try to look the folder filename /tmp. from there, you're going to paste the sysupgrade image.
17. Press, SHIFT+CTRL+T. Command box will pop up then type the the filename of the image that you copied and hit execute. It will install the system upgrade now.
18. restart and done.
19. you can log in now using LuCi. 192.168.1.1

Apart from the errors in this command: It is not recommended to blindly upgrade all packages, since this can lead to all sorts of trouble.
https://openwrt.org/meta/infobox/upgrade_packages_warning

@tmomas, until now i don't have any issues after executing those lines. :slight_smile:

Hi all.
I'm Trying to install a OpenWRT FW on a TP-LINK Archer C50 v4.
I found at compatibilty of devices just a Snapshot avaliable for this version:
https://openwrt.org/toh/views/toh_fwdownload
https://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/openwrt-ramips-mt76x8-tplink_c50-v4-squashfs-sysupgrade.bin

But when I try to install this snapshot the router show me the error: Erro Code: 4503
The uploaded file was not accepted by the device.

The TP-LINK Original FW is:
Firmware:
0.9.1 0.2 v0093.0 Build 180313 Rel.54477n(4252)

Hardware:
Archer C50 v4 00000002

Already tried to rename the file to TP-LINK name file, but it did not work.

Someone Know how to fix it?

Thanks in advance!!!!

@ismael.mota, try to read my post 2 days ago it might help you. :slight_smile:

friendly advice, do not flash your device directly with sysupgrade it will bricked your router. it happen to me. read more on the postings and you will find what you're look for. :slight_smile:

that's exactly what I did and I managed to brick it, my PC is not detecting it after connecting it through LAN1, it does momentarily when I press and hold the reset button but it goes back to the same state.

I read your post about returning your modem through warranty. If everything fails then I'll do the same but are there any steps that I could do to recover it?

try to use the approach of cowl0ver;

Router looks for an IP address of 192.168.0.66 and a file named tp_recovery.bin

  1. Setup your computer to 192.168.0.66 (SubnetMask /24 = 255.255.255.0) and connect it to LAN1.
  2. Start TFTP server (with tftpd64 ) and provide recovery file with it.
  3. To activate TFTP Recovery press and hold WPS/Reset Button during powering (8 sec.) on until WPS LED turns on.