Support for Archer c50 v4

that's exactly what I did and I managed to brick it, my PC is not detecting it after connecting it through LAN1, it does momentarily when I press and hold the reset button but it goes back to the same state.

I read your post about returning your modem through warranty. If everything fails then I'll do the same but are there any steps that I could do to recover it?

try to use the approach of cowl0ver;

Router looks for an IP address of 192.168.0.66 and a file named tp_recovery.bin

  1. Setup your computer to 192.168.0.66 (SubnetMask /24 = 255.255.255.0) and connect it to LAN1.
  2. Start TFTP server (with tftpd64 ) and provide recovery file with it.
  3. To activate TFTP Recovery press and hold WPS/Reset Button during powering (8 sec.) on until WPS LED turns on.

^ just want to share that I'm running my archer c50 v4 without issues now. I recently flashed it with the latest SNAPSHOT for the 2nd time around and it correct all the updates. looks like I'm running the stable release without any hassle anymore. :slight_smile:

How did You update it to the stable release?

@Tibit check from my post 11 days ago. i have posted with links. using " [SelfMade-Archer_C50v4-OpenWrt-blocktrron_c50v4-noboot ]"

I've added a new section specifically for the C50 v4 in the OpenWRT wiki based on the useful information contained in this thread.

https://openwrt.org/toh/tp-link/archer-c50

I've rebuilt 3 images based on OpenWrt 19.07-snapshot as of 25 July 2019 containing LuCI.

https://www.dropbox.com/sh/2j6v8b8gjafcal2/AABcCZ56zQ4nxXu15fMTHhODa?dl=0

I can successfully install OpenWRT to my C50v4 using TPlink web GUI and via TFTP. I've also tested the image to revert from OpenWRT to latest TPlink OEM firmware using sysupgrade.

Use LuCI to update to latest OpenWrt release.

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07-SNAPSHOT, r10269-5100629e32
 -----------------------------------------------------
root@OpenWrt:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/root                 2560      2560         0 100% /rom
tmpfs                    30020       456     29564   2% /tmp
/dev/mtdblock5            3712      1620      2092  44% /overlay
overlayfs:/overlay        3712      1620      2092  44% /
tmpfs                      512         0       512   0% /dev
root@OpenWrt:~#
root@OpenWrt:~#
1 Like

@bill888 so you mean, you've successfully flash the router with " [SelfMade-Archer_C50v4-OpenWrt-blocktrron_c50v4-noboot ]"??? but, LuCi is not functional or cannot be installed right??? so, you need LuCi right now so that you can flash the final sysupgrade image??? if yes, then you did the right thing.. tell me if im correct so that i will teach you how to upload the sysupgrade image and all the package that fail is going to be corrected. :slight_smile:

Update: the problem I witnessed where I could update package list but could not download any packages, has been identified/fixed. The packages were missing from the servers due to network/DNS issues.

I used the images I modified and instructions I uploaded to my new drop box folder contained in earlier post.

I then also used sysupgrade to install '20190425-openwrt-ramips-mt76x8-tplink_c50-v4-squashfs-sysupgrade-1.7z' which includes working LuCI, from niklas web page. However, it too cannot install any packages. I get same packages not found error message.

I just installed latest development snapshot onto a spare HH5A. No problems downloading and installing LuCI and other packages on that router.

so, you mean your good now using the latest snapshot HH5A?

No issue with HH5A but I would like to see what can be done with the C50v4.

There is only 8 MiB of flash in C50v4 compared to 128 MiB in HH5A. I may end up restoring the C50v4 to using TPlink firmware and use it as a cheap access point.

do you still want to use the one from from niklas web page? I did mine right from the 1st flash then 2nd sysupgrade but the packages had some errors from it. but, I managed to fixed it on the 3rd sysupgrade using the latest snapshot. all packages are available on my router now smoothly as it should.

I've reported it as a bug for the moment.
https://bugs.openwrt.org/index.php?do=details&task_id=2325

Update, my ticket has been closed because someone else has reported same problem for TL-WR841N v13
https://bugs.openwrt.org/index.php?do=details&task_id=2324

Hopefully, network problem will be fixed over next day or two.

hi i got error when i tried to install luci

root@OpenWrt:~# opkg install luci
Unknown package 'luci'.
Collected errors:
 * opkg_install_cmd: Cannot install package luci.
root@OpenWrt:~#

any help???

As the post above says, there were some problems with the packages in today's build. Try again tomorrow.

This is assuming you did the rookie stuff that you have to connect the router to the Internet and run opkg update before opkg install will work.

Package downloads working fine today after yesterday's glitch. I was able to install Luci and openvpn packages.

fwiw, C50 v4 (MT7628A 580MHz?) maxes out around 12 mbps via ethernet LAN to my VPN provider using Openvpn protocol, and about 9.6 mbps via wifi, with latest snapshot.

Compared to my WD MyNet N750 with 560MHz Atheros AR9344 returning closer to 14.5 mbps via ethernet running LEDE 17.01.4.

I used the HH5a openvpn client guide to install onto C50v4:
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=279

@n2f do you use archer c50 v4?

Hello from Japan!

I flashed your compiled image on to my Acher c50 v4 via TFTP.
It works perfectly.

I really appreciate your work :slight_smile:

1 Like

Hi from Ukraine. Works perfectly. Thanks!

Hello all,

I'm new to OpenWrt, and was interested in buying this router to flash. I have experience flashing Tomato and DD-WRT in the past, and am comfortable with TFTP and even the occasional debricking.

How easy is it to install Wireguard in particular on this router? I have seen speeds of 10 Mbps reported with OpenVPN, and if I'm correct, that should translate to some decent speeds with Wireguard, but I can't find any info on anyone attempting to install Wireguard on it. Is it as simple as "opkg install wireguard"?

Thanks!

https://openwrt.org/docs/guide-user/services/vpn/wireguard/start
https://openwrt.org/docs/guide-user/services/vpn/wireguard/basic