Support AIoT AC2350 Xiaomi?

OK, another - maybe lame - question: if the high CPU usage comes from the firmware issue, is it possible to extract the firmware from the original xiaomi's and use that?

The issue is not in the WiFi hardware firmware, but rather in the ath10k or mac80211 modules. Stock images use tricks with offloading packets that are not fully implemented in OpenWRT.

1 Like

Thanks for clarifying and for your efforts! Too bad this has that bad CPU - I'm going to return it, xiomi 4a giga is almost half the price and on mt76 gives me ~450 MBps.

I have just flashed mine and upgraded all packages, i see minimal difference between kmod-ath10k and kmod-ath10k-ct, original firmware was around 330-350 down and 260-280 up, after i flashed it and enabled offloading i get 290-310 down and 270-400 up, really intrigued why download went down but upload went up.
It performs a little bit better then my Archer C7, not by much though, with that being said anyone knows some good hardware for WIFI only interested in AP part, routing i do in a separate machine.

1 Like

@eisaev Hey man , first of all , nice work on the AC2350!

So I bought 2 AC2350 to increase my wifi range and unfortunately the EU range sucks. My questions here are:

  • On your github seems possible to inject the SSH access through browser , not needing a hacked router like you say here on this topic. Is this still possible ? (Edit: Yes it is , I got it now)
  • I've tried to downgrade to 1.3.8 firmware by PXE (last tiny pxe is TFTPd:DoReadFile: test.img , so im assuming it correctly downgraded??) and when I try to inject the ssh key gives me a 403 Forbiden error. How can I downgrade to 1.3.8 so i start the hacking on ssh ? (Yes, i got it to work. My problem was that i was using the STOK variable before finishing all the steps of the router. We can put him on DHCP for faster setup)

Now another question , I've managed to flash the mod.7 firmware with success but I cannot login to SSH again... it complaints of the password. I've calculated using the site and using bash, was using the bash generated one... managed to scp and run everything but now looks like the password is changed. is that possible ? How can i find the new pwd ? Should i start from chinese firmware again ?

What firmware version did you have from the factory? If it was 3.0.36, then you can change it to 1.3.8 directly from the web interface.
The mod7 firmware does not change the password and it should be the same as it was on the stock firmware. You can send me the serial number by private message and I will generate a password for you.

I had the latest , i think is 3.0.36 or something. My post had an error.... after the mod.7 flash the password remained.

The change comes after running the next steps , flashing bdata and art (didnt manage to reach art because of pwd)

So mod7.bin is OK




mtd write /tmp/crash_unlock.bin crash

looks ok and then after the reboot ssh doesnt accept the password calculated on the first steps. I'll pm you the serial but maybe i have to start from scratch (1.3.8 then inject ,flash etc)

OK , following up on this... IDK why the password stopped working but after 2 days off... rebooted the router, SSH + scripts run and thats it. working on maximum power.

Now I'm gonna repeat the process with the second AC2350 I have standing here.

Thanks for your work @eisaev !!!

1 Like

Hi There,

just tried the sequence but I never get a {β€œcode”:0} reply in the browser. SSH does not work.

Tried rebooting and resetting to default all the settings.

Any suggestions?


What message appears in the browser? Have you installed the Chinese 1.3.8 firmware?

thanks for the reply.
yes I did install the firmware and followed the instructions but the browser just times out.

Have you correctly copied the stok value? It needs to be copied from the same machine you execute the link on. If that is not the problem, could you try a different browser?

Different PC and same browser (chrome) did the trick.
thanks a lot

Support for this device has officially been added to the 21.02.2 second service release.


This topic was intended for adding support for this specific device.
Since official 21.02.2 images are available now, I will set a timer for this topic to close.


Because specific problems for this device with official releases are better handled in separate topics, in order to make finding relevant information easier. Who is going to read the previous 200-something postings, if he has a specific problem with 21.02.2 and wifi?

Therefore: Please open new topics for any open issues with this device.

Thanks! :slight_smile:

just a simple question: has this router support for wifi mesh?

1 Like

Any one tried to solder a female usb port after disconnecting the non working Iot radio?
USB Internally connected QCA6006 USB IoT radio (currently unusable, not supported by ath6kl)
Is there a chance to add the support in a future release?

please take a look to this

I tried :slight_smile:

I am the author of this hardware mod.

1 Like

Ver nice effort eisaev,
Could you please help us and explain the steps short guide maybe :grinning:

Thank you for your efforts

There is nothing complicated there, but to write instructions, I need to at least repeat the entire procedure several times myself, otherwise I will probably miss something and mislead the participants repeating the mod. But unfortunately, I am now busy surviving in a country whose government has unleashed a war, and citizens who do not support these actions suffer from this, among others.
In short (see

  1. Solder the USB connector according to the scheme
  2. Cut two wires (D+ & D-) on the board
  3. Build OpenWRT firmware with USB support and with the necessary modules yourself or download firmware here