Suddenly cannot connect to HTTPS websites as of this morning

Router: ASUS RT-AC58U
OpenWrt 21.02.3 r16554-1d4dea6d4f

I have had this setup with my Fios service for the past 3 months with NO ISSUES. I was using my internet just last night as usual. I woke up this morning to find out that not a single device in my house is able to connect to HTTPS websites.

When I go to http://portquiz.net/ I can connect. If I try with port 443, I get nothing. I can ping google.com, I can ping 8.8.8.8, but I cannot access google.com on a browser. Nothing works on any device besides plain port 80.

I have tried rebooting the router, and also tried disabling peer DNS and using google's dns to no avail.

Please let me know where I should go from here. I'm nearly ripping my hair out trying to figure out this mystery issue that seems like it has no business springing up out of nowhere, especially when I have not touched the router settings in months. Thanks.

Easy test to see if this is router related (which seems unlikely) is to refresh the opkg package list. This will connect to the openwrt servers by https.

If that fails as well I'd suggest the issue is upstream.

Alternatively you could connect a pc direct to your FIOS box and try https bypassing the modem - but make sure the pc has a firewall enabled.

Thanks, opkg update hangs on download so it seems that it is upstream. In fact, it seems my Fios bill is actually overdue by two months, which i did not realize. Hopefully that is the issue.

It is weird though, that they would still allow port 80 connections...hmmm

probably a https redirect rule to a notice.
as a side note - openwrt is great for these situations - you can fire up an openvpn on port 80 on some VPS and have internet up & running until the ISP fixes the issue (in this case the payment that can take a few days sometime)

1 Like

Verizon is rolling out IPv6 support on Fios. Any chance that might be involved in your weird behavior?

Yeah thats a good tip.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.