Hey all, I am using a TP Link Archer AX23 running the latest Openwrt 23.05.04, Which is connected to a RPI4 running the same openwrt release and conducting SQM on a 300/350 connection.
I unfortunately don't have any devices with a ethernet port and hence can't determine if wifi is the issue or its the whole setup.
I am unsure what changed because some time back i fine tuned my AQL settings and achieved near 0ms bufferbloat on upload while getting a speed of over 200mbps.
Now, I am getting upwards of 300ms bufferbloat over wifi.
https://www.waveform.com/tools/bufferbloat?test-id=f8c5768d-8ed1-433b-b428-7e90ad8c159b
Compare that to
https://www.waveform.com/tools/bufferbloat?test-id=f3301348-2874-4eb3-9028-00f7d1ccb5a1
{
"kernel": "5.15.162",
"hostname": "OpenWrt",
"system": "MediaTek MT7621 ver:1 eco:4",
"model": "TP-Link Archer AX23 v1",
"board_name": "tplink,archer-ax23-v1",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.4",
"revision": "r24012-d8dd03c46f",
"target": "ramips/mt7621",
"description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
}
}
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdc2:b207:2428::/48'
option packet_steering '0'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.0.2'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.0.1'
option delegate '0'
list dns '192.168.0.1'
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdc2:b207:2428::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.0.2'
option netmask '255.255.255.0'
option ip6assign '60'
option gateway '192.168.0.1'
option delegate '0'
list dns '192.168.0.1'
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
option band '2g'
option htmode 'HE20'
option cell_density '0'
option channel 'auto'
option country 'IN'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'TP-Link_F5B2'
option encryption 'sae-mixed'
option key '31july2006Ar'
config wifi-device 'radio1'
option type 'mac80211'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
option channel '161'
option band '5g'
option htmode 'HE80'
option cell_density '0'
option country 'IN'
config wifi-iface 'wifinet1'
option device 'radio1'
option mode 'ap'
option ssid 'TP-Link_F5B2_5Ghz'
option encryption 'sae'
option key '31july2006Ar'
option network 'lan'
config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'ap'
option ssid 'TP-Link_F5B2_5Ghz'
option encryption 'psk2'
option key '31july2006Ar'
option network 'lan'
option disabled '1'
I have manually disabled the DHCP and Firewall services on the AX23 and let the RPI4 handle those.