Stuck with HT-TM02 can't access

I was just trying open-wrt on my HooToo Nano HT-TM002. It worked fine but then i decided to update the open-wrt version and i might have installed the wrong package. The device is powering on, being displayed in my laptop as Unidentified Network and i cant access page. Also IP-Config is missing the data of default gateway for the same.

Which OpenWrt image exactly have you flashed?

This one
and initially this is what worked for me..

i have a serial console connected to the unit, but don't know how to use it, connect to pc and stuff

plug in the USB TTL to your PC, if using Windows, it'll get a com port assigned, use
Putty and open a serial connection using that same com port.

unable to do, so , is there any proper way to connect with you so that u can give me a more in depth help with it

post photos of the PCB, and we might perhaps be able to help you.

couldn't find any of those at :frowning:

photos of device or of what bro?

Feel free to post photos of yourself and your family, but PCB = printed circuit board.

serial != ethernet.

yes that i know bro, i just shared it for reference regarding my problem.

disable the flow control all together.

is the serial port completely dead, or are you getting garbage ?

how to check it? i dont know. when i click on open, nothing happens, it is my first time ever trying to work with serial port

It'll stay dead until you try to switch on your HooToo.

Post a pic or link to the USB serial device you're using.

this was the only product available in my entire town market, and yes, i know the solder looks sketchy but they are tight and also no wire is shorted