Stuck at fresh install (TL-WDR4300)

I have a tplink n750, not used for a was running 19.something from the ‘lede’ era

I tried to ‘upgrade’ it to the latest OpenWRT using the commandline with the sysupgrade image. It kind of worked in that I can login with ssh as root but the Luci web interface is gone. Reinstall with opkg complains about a readonly filesystem

Should I completely reset the router to factory before reinstalling OpenWRT again or is there another solution

there's no N750 in the ToH, what device are you using, specifically ?

1 Like

Ah, yes. It has N750 in the front but its a TP-Link WRD4300.
Basically, I can login with SSH, but there are no Luci packages installed (opkg list-installed does not show them)

If I try to update, opkg downloads the package lists. I can run opkg install luci,
but then it failes with readonly filesystem.

bottomline: how can I get Luci on the router to setup all the interfaces.
Remember, it was running 19.02 with Luci

Do I first need to add extra space via an overlay on a USB stick and if so, how should I do that?

not sure it'll work, try running firstboot && reboot 1st, to reset the device.

paste any output, it usually helps.

which WNDR4300 is it anyway, v1 or v2 ?

WNDR4300 is Netgear.


ok, I was reading the wrong device pages.

advise still stands though.

you can also attempt the recoveries described at

Snapshot builds do not contain Luci. Do a sysupgrade -n with the 22.03.3 image. The old 19.07 settings can't be used in any case since there is a change from ar71xx to ath79.

Since there is only 8MB flash, installing anything major will probably require using image builder or firmware selector or attended sysupgrade in order to optimize packing in the ROM.

I don’t get it. I did use a stable image, not snapshot. The stable version does not seem to contain Luci either. I have a v1 model btw

For my own reference (and others stumbling upon a similar issue):

I managed to recover the WRD4300 v1 to a fully working OpenWRT 22.03.3 version using the following method:

  1. added an empty redundant 4GB USB stick on USB port 1

  2. Downloaded a custom sysupgrade via the "Download OpenWrt Firmware for your Device" page.

Using the "Customize installed packages and/or first boot script" option I added the packages:

luci kmod-usb-storage usbutils parted block-mount kmod-fs-ext4 e2fsprogs

and requested the build --> 7.2 MB, tight fit for this router

  1. copied the sysupgrade custom firmware to the router using scp <custom firmware build> root@

  2. login on the router and run sysupgrade -i <firmware>

  3. login again as root

  4. follow the guide on extroot

  5. further configured the router with the luci interface and addedd a few extra packages like adblock etc.

1 Like