Stuck after flashing ZTE MF283+

Now I will describe the boot up process as it does not boot in one go, well it does but....
It kinda struggles to find the right network, which it eventually does not find (Vip WLAN_4475A3) but in the end it always "connects" to the "Unidentified network".
Sometimes it does find it during the boot up but then, after a while
switches over to "Unknown network".

During the boot up I monitored the adapter's status messages in real time by going to
the Control Panel > Network and Internet > Network Connections
and watching the boot progress.

Booting up:

  • Starts with "Network cable unplugged" and then I switch ON the router

  • The power led (blue) turns on and stays on all the time

  • Then after a second the 3/4g & LTE Signal led blink once simultaneously (blue led light)

  • This is followed by "Attempting to authenticate" message

  • Then it says "Network cable unplugged"

  • Then "Attempting to authenticate"

  • After this the 3/4g led starts rapidly and continuously blinking in green color

  • After a while I get the "Network cable unplugged" again (3/4g led still blinking green)

  • Then "Attempting to authenticate" (3/4g led still blinking green)

  • Then it finally finds "VIP WLAN_4475A3" or most of the time "Unidentified network" (3/4g led still blinking green)

  • Then it goes to "Network cable unplugged" (3/4g led still blinking green)

  • Then it goes to "Attempting to authenticate" again (3/4g led still blinking green)

  • Then the green blinking 3/4g led finally stops flashing and turns into blue color and it
    finds the "Unidentified network"

    Occasionally it will start booting again but this happens very sporadically.

  • It takes just over a minute each time for the final connection to "Unidentified network"
    to get established and for the 3/4g green blinking led to turn into steady blue

  • Only ONCE did the router establish connection with the by the ISP assigned SSID
    (Vip WLAN_4475A3) and remained connected but still no LuCI as could
    not be reached

    That's when I did a ping test which I am posting in one of the screenshots below.
    Other times I have tried to run the ping while the router was booting (3/4g indicator
    blinking green)

    I will post the screenshot of this below too.

Here we go:

These are my internet protocol settings which I have set up manually:

Capture Recent 0

I have validated settings upon exit

Then I have pinged my NIC (local host) to make sure that everything is working on that side:

Everything seems fine here.

Once the final connection gets established with "Unidentified network" I tried pinging again:

After that I started Putty to try to connect through SSH so I was waiting during to boot up for connection to get established with "Vip WLAN_4475A3" network.....

Brief moment during the boot up when the connection gets established with by the ISP provided SSID and me trying to connect through Putty:

With this result:

This is the ONE & ONLY instance when after the boot up connection got established and remained connected with the ISP network's SSID but it did not fix anything as remained unreachable too.

After the ping test I also ran the ipconfig /all command while being connected to the "Vip WLAN_4475A3":

Last screenshot I made is of the situation when I manually assigned the preferred DNS server which I kept the same as the default gateway which resulted into a boot up like it does all the time with one exception and that is that when the connection to the "Unidentified network" finally got established, the blinking green led light on the 3/4g indicator did not turn to blue but instead it just turned off completely.... so the only led that remained on was the power led....

Like I mentioned at the very beginning of my post, I am a newbie when it comes to OpenWrt but I am learning with each step that I take.

I hope that anyone of the more experienced members and/ or developers can at least point me into the right direction. I am more than willing to do all the hard work by myself.

Or should I just try to reach out and contact the person who made the firmware for this very router?

That would be Lech Perczak...

I did not mean this in a bad way but as a last resort as I see that only 2 members have helped me out so far so I was contemplating that maybe nobody knows possible fixes and/ or has useful suggestions on how to resolve this issue.

I saw Perczak's gmail address in the git section where he posted his findings and the idea naturally occurred.

I will post the last thing I tried after connecting the router to 2 different computers where the behavior is the identical like previously described in the thread above.
My last experiment was to try and consecutively flash the OpenWrt firmware to the router three times in a row.

Eventually that did not change anything and after that I tried assigning the default gateway under IPv4 settings into the OpenWrt default one: instead of the default one that's normally used in Tftpd server.

I did so cause I thought that it might help to flash the router additionally if there was some kind of ISP protection to do so the regular way. As I have already flashed the router it would be logical to assume that the default gateway changed from to OpenWrt's default

After transferring the firmware to the router I went through the log files:

In the first line it says:

"Connection received from ........... "

Which makes me believe that the firmware was never completely or successfully flashed cause otherwise it would be saying "Connection received from"

This makes me conclude that (at least in my case) using the TFTP method does not work for the ZTE MF283+ router.

I quote Lech Perczak:

" There are two installation methods:
(1) Using serial console and initramfs-kernel - recommended, as it
allows you to back up original firmware, or
(2) Using TFTP recovery - does not require disassembly.";a=commit;h=59d065c9f81c4d1a89464d071134a50529449f34

I have read the forum rules and I understand that people are encouraged NOT to post anything rather then to post "anything" that does not really contribute to solving the issue.

However, I must say that I am pretty disheartened by almost no reactions at all as I was under the impression that many experienced users and developers visit this forum and actively help other less knowledgeable and less experienced members.

Hence I have decided to tag the following forum members as I have seen them proactively react and offer help in more than few other posts. And from what I have seen they really know what they are talking about.

I offer my sincere apology in advance if you find it rude but @discobot thought me it might be useful and so he showed me how to involve members into discussion by tagging them.


So my question would be:

Is it possible that ISP made the router impossible to flash by only using the TFTP server?

Can I instead use a tool like this:

or this:

Can someone guarantee that I will be able to flash the router when using any of the tools above while following the serial console and initramfs-kernel method as described by Lech Perczak:

"(1) Using serial console:
To install OpenWrt, one needs to disassemble the
router and flash it via TFTP by using serial console:

  • Locate unpopulated 4-pin header on the top of the board, near buttons.
  • Connect UART adapter to the connector. Use 3.3V voltage level only,
    omit VCC connection. Pin 1 (VCC) is marked by square pad.
  • Put your initramfs-kernel image in TFTP server directory.
  • Power-up the device.
  • Press "1" to load initramfs image to RAM.
  • Enter IP address chosen for the device (defaults to
  • Enter TFTP server IP address (defaults to
  • Enter image filename as put inside TFTP server - something short,
    like firmware.bin is recommended.
  • Hit enter to load the image. U-boot will store above values in
    persistent environment for next installation.
  • If you ever might want to return to vendor firmware,
    For this router, commonly used by mobile networks,
    plain vendor images are not officially available.
    To do so, copy contents of each /dev/mtd[0-3], "firmware" - mtd3 being the
    most important, and copy them over network to your PC. But in case
    anything goes wrong, PLEASE do back up ALL OF THEM.
  • From under OpenWrt just booted, load the sysupgrade image to tmpfs,
    and execute sysupgrade."

Can please someone help me out?

If there is no guarantee it will work I'd then rather add some some money and instead of buying UART modules, buy something like a Xiaomi 4A router.

I actually do prefer flashing the ZTE MF283+ router that's in my posession.
Any input or directing to source of information that would help me out sort out this problem would be very much appreciated.

Kind regards.

Hi! To find out what I can do, say @discobot display help.

1 Like

I see that the tftp finished sending the file to the router.

This is wrong assumption. You expect the connection from . The new IP of .1.1 will not be present in tftp process.
Change your PC address to dhcp again and connect it to the router to verify if it will get the IP from dhcp server.

1 Like

Hi trendy.
Thank you for replying.

Yes the file gets transferred and the flashing itself occurs but eventually after the flashing I get stuck with "unidentified network" and no possibility to get to the LuCI GUI.
So the router is NOT bricked or anything. ( I have described all the symptoms and the steps I have taken since I started the topic)
It just can not be found/ accessed.

I have tried (multiple times) on 2 different PC's (Windows 10 and Windows 7) changing addresses (dhcp & assigning manually) to no avail.

""This is wrong assumption. You expect the connection from . The new IP of .1.1 will not be present in tftp process.""

On the contrary, I DO expect a connection from "' as I have previously flashed it 2 times with OpenWrt firmware already and the ISP's web interface is not accessible anymore. So I do believe that it should already be there instead of the stock '' address.

So this very issue maked me think that the flash can not be performed for 100% and that is the very reason that after the flashing the router can not be accessed, neither through stock web interface or LuCI. Above I have posted results when pinging hte router.

When I flash back the stock firmware, I can access the router normally through it's web interface.

So I believe it all boils down now to buying the "USB to TTL UART Serial Converter Module" or not. All depending on if it will help me flash the router or not.

I do not mind buying it and opening the router but I first need to know if it will work before wasting any money on it.

I need to go out now but I will be back in couple of hours again.

Kind regards.

1 Like

Thank you for you confidence. You can talk to me privately about why I wouldn't have usually responded. In this case, I didn't begin reading likely after I saw the model number in the title.

Now that I have navigated relevant essays and pictures...I would suggest this. Your descriptions are quite long, but:

Are you able to revert to OEM again?

Also, sometimes your screenshots show you did not change back to DHCP after flashing; but 0 B Rx means it doesn't seem to matter anyways.

The address is the one that the bootloader has. It is not connected to the one the OpenWrt assigns to the router after it is fully booted.

I cannot say if it will work or not. However I shall say that there other routers more OpenWrt friendly and with higher specs. So it comes down to asking yourself if it is really worth it, both time and money wise.

1 Like

Hi lleachi.
Thank you very much for replying.

Yes, I am able to go back and forth between OpenWrt & OEM whereas I can enter the OEM web interface but can not do so with LuCI.

I did not post any pictures with switching back to dhcp after flashing but I did so right after flashing and I only switched it to manually assigned IP address because @daniel suggested doing so to check if it would help.

I need to go out now so I will surely send you a private message regarding "not responding" as soon as I catch some time.

Thank you again for your reaction.