Struggling with migrating to DSA

Hi

I have some issues, migrating my Accesspoint to the new DSA architecture.
I am using a TP-Link C6v3, because my old AP died.

On the WAN interface, I have a trunk with 3 vlans
VLID10: LAN
VLID20: Guest
VLID30: IoT.

I now created 3 .1q devices:
WAN.10
WAN.20
WAN.30

and added them to 3 bridges:
LAN (WAN.10,LAN1,LAN2,LAN3,WLAN0-1)
Guest (WAN.20,WLAN0-2)
IoT (WAN.30,WLAN0-3)

I also created 3 WLANS:
LAN
Guest
IoT.

On thw WLAN side, everything is fine.

However, I assigned the LAN Ports of the router/AP to the first bridge.
A computer hooked up to that LAN port is not able to communicate to the network at all.
In fact, I am not able to obtain an IP address via DHCP.

I can ping all WAN interfaces from any machine coming from the 'outside' WAN intergface.

Obviously, I am doing something completely wrong.
Is there somebody who can help me?

Cheers,
Christopher

p.s. see my network configuration

# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd40:02ba:a89d::/48'

config interface 'panic'
	option proto 'static'
	option device 'lan4'
	option netmask '255.255.255.0'
	option ipaddr '192.168.10.1'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '10'
	option name 'wan.10'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '20'
	option name 'wan.20'

config device
	option type '8021q'
	option ifname 'wan'
	option vid '30'
	option name 'wan.30'

config interface 'LAN'
	option proto 'static'
	option ipaddr '10.10.0.6'
	option netmask '255.255.0.0'
	option gateway '10.10.0.1'
	option device 'LAN'

config interface 'Guest'
	option proto 'static'
	option ipaddr '10.20.0.6'
	option netmask '255.255.0.0'
	option gateway '10.20.0.1'
	option device 'Guest'

config interface 'IoT'
	option proto 'static'
	option ipaddr '10.30.0.6'
	option netmask '255.255.0.0'
	option gateway '10.30.0.1'
	option device 'IoT'

config device
	option type 'bridge'
	option name 'LAN'
	option bridge_empty '1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'wan.10'

config device
	option type 'bridge'
	option name 'Guest'
	list ports 'wan.20'
	option bridge_empty '1'

config device
	option type 'bridge'
	option name 'IoT'
	list ports 'wan.30'
	option bridge_empty '1'

I do not use Vlans presently, but the above articles are good references to your task.

I will share my knowledge, once I solved my issues and understanding how DSA are working.

I have 4 VLANs in use in DSA. This is from my dumb access point. Hope it's helpful as a reference for you:

/etc/config/network
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd90:d55a:8500::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	option ipv6 '0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'

config interface 'lan'
	option proto 'dhcp'
	option device 'br-lan.10'

config interface 'guest'
	option proto 'none'
	option device 'br-lan.3'

config interface 'homeoffice'
	option proto 'none'
	option device 'br-lan.4'

config interface 'iot'
	option proto 'none'
	option device 'br-lan.5'

config bridge-vlan
	option device 'br-lan'
	option vlan '10'
	list ports 'lan1:u*'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '5'
	list ports 'wan:t'

config device
	option name 'br-lan.3'
	option type '8021q'
	option ifname 'br-lan'
	option vid '3'
	option ipv6 '0'

config device
	option name 'br-lan.4'
	option type '8021q'
	option ifname 'br-lan'
	option vid '4'
	option ipv6 '0'

config device
	option name 'br-lan.5'
	option type '8021q'
	option ifname 'br-lan'
	option vid '5'
	option ipv6 '0'

config device
	option name 'br-lan.10'
	option type '8021q'
	option ifname 'br-lan'
	option vid '10'
	option ipv6 '0'

config device
	option name 'wlan1'
	option ipv6 '0'

config device
	option name 'wlan1-1'
	option ipv6 '0'

config device
	option name 'wlan1-2'
	option ipv6 '0'

config device
	option name 'eth0'
	option ipv6 '0'

config device
	option name 'lan1'
	option ipv6 '0'

config device
	option name 'lan2'
	option ipv6 '0'

config device
	option name 'lan3'
	option ipv6 '0'

config device
	option name 'lan4'
	option ipv6 '0'

config device
	option name 'wan'
	option ipv6 '0'
3 Likes

@darksky
Thanks a lot, your confiuguration worked perfectly for me.
You saverd my day.

To summarize it,

  • You first created a Bridge "br-lan", which basically replaces the "Switch" from older OpenWRT releases. (Network -> Interfaces -> Devices)

  • You then added all physical Ports to that bridge. In our case, LAN1-4 (the "switch" ports) and WAN. (Bridge-device -> General device options -> Bridge ports)

  • In the next stel, you configured your VLANS, setting the WAN port as a trunk (Tagged) and LAN1-4 at access ports (Untagged). (Bridge device -> Bridge VLAN filtering)

    • This configuration implicitly created the interfaces br-lan.X (X stands for the VLAN).
  • In the last step, you configures Interfaces with IP addresses to the br.X interfaces. (Network -> Interfaces -> Interfaces)

1 Like

Which package do I need to install in order to have Bridge VLAN filtering tab?

I believe it is either supported or not. Not using the legacy network>switch interface.

You don't need to install any additional packages.
I am using OpenWRT 22.03, and I found the VLAN filtering tab in
Open your newly created Bridge and you will see the VLAN filtering tab

1 Like

Thanks for the nudge in the right direction. I was clicking on Configure... button of my VLANs expecting to get to the VLAN filtering page (and assumed I'm missing some luci-package as I seen it before :smile: ) while it's only available from bridge interface. Makes sense.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.