Struggling with 802.11s mesh, no SSID

Hi all

I am trying to setup a mesh network in my house.
I have started with a TPLink WDR3600 with Openwrt 19.07.2
I am focusing on the 2.4Ghz radio, removed the AP station, installed wpad-mesh-openssl and set the following in /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option channel '6'
        option htmode 'HT40'
        option txpower '22'
        option path 'platform/ahb/18100000.wmac'
        option country 'IT'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option channel '48'
        option htmode 'HT40'
        option txpower '19'
        option country 'US'
        option legacy_rates '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'MenionP1_5Ghz'
        option encryption 'psk2'
        option key 'xxx'

config wifi-iface 'mesh'
        option device 'radio0'
        option network 'lan'
        option mode 'mesh'
        option mesh_id 'MenionMesh'
        option mesh_fwding '1'
        option key 'xxxx'
        option ssid 'MenionMesh'
#       option mesh_rssi_threshold '0'
        option encryption 'psk2'

iw dev reports

phy#0
        Interface wlan0
                ifindex 9
                wdev 0x2
                addr c4:6e:1f:08:9d:0b
                type mesh point
                channel 6 (2437 MHz), width: 20 MHz, center1: 2437 MHz
                txpower 21.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcoltx-bytes tx-packets
                        0       0       189     88      0       0       0      87699            296

system.log says

Sun Apr  5 10:02:21 2020 daemon.err wpa_supplicant[1644]: Using interface wlan0 with hwaddr c4:6e:1f:08:9d:0b and ssid ""
Sun Apr  5 10:02:21 2020 daemon.notice wpa_supplicant[1644]: wlan0: interface state UNINITIALIZED->ENABLED
Sun Apr  5 10:02:21 2020 daemon.notice wpa_supplicant[1644]: wlan0: AP-ENABLED
Sun Apr  5 10:02:21 2020 daemon.notice wpa_supplicant[1644]: wlan0: joining mesh MenionMesh
Sun Apr  5 10:02:21 2020 daemon.notice netifd: Network device 'wlan0' link is up
Sun Apr  5 10:02:21 2020 kern.info kernel: [   37.068600] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Sun Apr  5 10:02:21 2020 kern.info kernel: [   37.075377] br-lan: port 3(wlan0) entered blocking state
Sun Apr  5 10:02:21 2020 kern.info kernel: [   37.080857] br-lan: port 3(wlan0) entered forwarding state
Sun Apr  5 10:02:21 2020 daemon.notice wpa_supplicant[1644]: wlan0: CTRL-EVENT-CONNECTED - Connection to 00:00:00:00:00:00 completed [id=0 id_str=]
Sun Apr  5 10:02:21 2020 daemon.notice wpa_supplicant[1644]: wlan0: MESH-GROUP-STARTED ssid="MenionMesh" id=0

it seems that there is no SSID assigned to the network which is confirmed also by Luci
It is the same even without the "option ssid 'MenionMesh'" in wireless config
After the setup I see an "hidden network" but I cannot join to it even if specifying the SSID
What am I doing wrong?

Thanks for the help!

I've been through a similar situation and it boiled down to my understanding of how the mesh works.
In the wireless config you have the radio split into an AP and a mesh portion. The mesh portion will only mesh with other radios configured to have the same mesh_id. The radio interfaces that have the same mesh_id will talk to each other but won't allow non mesh clients to connect directly to the mesh. You need another radio or another interface on the same radio set up as the access point and then put the mesh interface in your lan bridge. If that makes sense, I think I am correct.
My mesh config

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'HT20'
	option disabled '0'
	option country 'FR'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2+tkip+aes'
	option key 'my AP passwd'
	option ssid 'BatMesh☠️'

config wifi-iface 'mesh0'
	option device 'radio1'
	option ifname 'mesh0'
	option mode 'mesh'
	option mesh_fwding '0'
	option mesh_id 'MeshNet'
	option encryption 'none'
	option network 'nwi_mesh0 lan'

My forwarding s '0' as I am using batman-adv for routing not 80211s and its setup unencrypted at the moment as this is the first time I've tried to set up a mesh and didn't want the added failure possibilities of encryption causing problems while I am learning.
A wifi scan shows my AP BatMesh and a which is the mesh point. I have 3 nodes up currently and it seems to be working although its not what you'd call fast.

2 Likes