Strong 1200 / MTC WR1201 bricked - TFTP or serial recovery?

Hi everybody!

I successfully bricked my Strong 1200 router while fiddling with it. If someone knows the serial pinout, I'd appreciate if they shared it, along with some specific instructions, if there are any. I checked the uboot of the device and it can receive images via TFTP, if anybody is familiar with this method for this device, I`d highly appreciate it.

Thank you!

Maybe you could mention @vk496 (don't, I did it already) who created the image for your device.

Hello @estudio and welcome.

Recovering the Strong over tftp is the same as usual for most of the routers: a tftp server serving the file. (

When router is booting, interrupt the u-boot process and use the option 2 (Load system code then write to Flash via TFTP. )

Let us know if you have any trouble


Thank you for clearing that up for me. Looking into the uboot image I saw server ip and for the receiver (the router) is is that right? Also, is there a specific name i must use for the image? And finally, how the heck do I interrupt the uboot process?

Thank you very much for helping me out.


I got stuck right at the beginning...

Do I do the TFTP flashing via serial and telnet? I`d need serial pinout for the router. I have serial adapter at hand.

I tried setting up a TFTP server at and serve uboot.img to the router via normal ethernet connection, which is supposedly, but no luck.

Please advise! Thank you.

There is no automatically starting built in TFTP recovery. You will need to do it manually on serial.

I have a HooToo AC1200 which I think is identical hardware. Pry the front cover off. You will be looking at the non-component side of the board. Toward the left side (looking at it from the front) there is a white box around 6 holes on 2 mm spacing. This is the serial port. The pinout is from top to bottom GND GND RX TX 3.3 3.3. There are probably no pins in the holes, so you can add them from the front side. The GND will be difficult to solder due to no thermal relief; find a different ground point.


To trigger the recovery, pressing the desired option (number 2) during the boot should be enough. If the keyboard input is not recognized during the boot, then you need to maintain the reset button while turning on the device.

The rest should not be a problem.



Thank you for the pinout, seems right on this motherboard aswell. I will add pins on the component side as you advised, would speed up the job if I have to try it more than once.

After that, I connect to the serial port via Putty and I should see the serial output of the uboot process, then I guess I can input option 2 somehow.

Will do all the soldering today and see where it goes.

Thank you, I will get back to report how it went.


Hello. I attach a picture with my pinout... When I connect the lower 2 pins to the VCC of the USB serial adapter get shorted for some reason, and disconnects form device manager. Any ideas what I might be doing wrong?

Thank you.

You must not connect Vcc.

Then use the power supply of the router normally?

You don't need power. TX, RX, and Ground.

Sounds straightforward... I am no newbie to serial communications, and while my soldering might not be the nicest, it gets the job done. I connected GND, router RX to adapter TX, router TX to adapter RX. No power supply and no VCC connected as advised. I tried holding the reset key on the router board while connecting the pins. nothing happens. Any idea what I do wrong???

Swap TX and RX just in case...

I tried that as first resort.

Got it working! Need the power supply, though.
I can interrupt boot process, and now I am here:

2: System Load Linux Kernel then write to Flash via TFTP.

Warning!! Erase Linux in Flash then burn new one. Are you sure?(Y/N)

y Please Input new ones /or Ctrl-C to discard

Input device IP ( ==:

This device IP is it the routers, or the TFTP servers IP? To me it seems like it is the router itself. How do I proceed?

Thank you!

Use option 1 instead-- TFTP to RAM then boot.

Prepare your TFTP server with the initramfs build of OpenWrt. Give it a short filename. Set the server PC to a static IP such as

The bootloader option 1 menu gives you 3 settings. first is device IP (the router) which you can leave at Then your server IP and the file name.

The bootloader should then TFTP boot the initramfs OpenWrt. Log in to OpenWrt and use it to flash the sysupgrade build. It should then be able to reboot directly from flash.

I feel like an idiot here...

After selecting option 1, it asks for the device IP as you told.

1: System Load Linux to SDRAM via TFTP.

Please Input new ones /or Ctrl-C to discard

Input device IP ( ==:

As you see, after I Enter at the command line it just sends it via terminal, then repeats it back, no new query for server ip and file name, I just tried to input them, thinking there was no feedback from the router. 2 way communications are obviously working, as it accepts the data when chosing the option.


I am still stuck with this recovery thing. Any ideas what I do wrong with the new IP adress?

Did you tried to just press Enter for using that IP by default?