Stripped Archer C60 V2 Firmware


I am trying (unsuccessfully) to revert to the original Firmware on my TP-Link Archer C60. Does anyone have a copy of the firmware with the bootloader section stripped so that I can load it from the GUI

1 Like

Hello, I'm also trying to revert to the original firmware. I am waiting for someone to post the stripped firmware link. Thanks!

Can you get this file ?
I need to restore back to stock this model but I cant.

Can you help me ?

hey didi you succed to get the stripped firmware?

Let me know if you're done successfully

As I know the Image file ( Archer C60(EU)_V3.0_190115.bin) doesn't contain uboot and there is no need to strip the original image

I tried installing the firmware from TPL website for my c60 v3, but in vain. This doesn't seem to work either & neither does the stripped firmware. I guess we have no way to go back to stock firmware from Openwrt on TPL C60 v3.

@Shrieram Please open a new topic for your C60 v3 problems.


1 Like

the link is dead ...
can you upload it again please

Sorry for Delay in response

Test it and let me know
Thank You

thanks for replay is it working for us version?

You should test it
I made it before and worked for me about 2 years ago


I try to flash it with tftp recovery it does not work
use the luci (force install) also not working

Your router is US or EU Version?! Which one?!

it is us edition

That FW you use befor is for EU version !! that's why didn't work

1 Like

thanks a lot I will try this method

According to this video you don't need to stripped firmware, just upload openwrt to your router then follow the structure on the video