Strange wifi problem

Thanks a lot if you can help. I can see in luci that the client is associated. But there is no internet connection at all. On the laptop, it does not show as if it is connected. I am on 9.07.7 r11306-c4a6851c72 and updated the router earlier. I don't know if this has anything to do with it.

My wifi configuration file reads:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option htmode 'HT20'
        option txpower '20'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'Sun.Sea'
        option network 'wan wan6'
        option key 'sorryIforgot'
        option wmm '0'
        option encryption 'psk2'
        option ieee80211w '2' 

Perhaps this is helpful:

I also tested with an open network, no password, etc. And the same problem: no internet connection.

What version did you upgrade to? Did you keep settings or did you allow it to reset?

This looks very, very wrong. It should probably be lan.

If that doesn't fix the issue, we'll need to see your complete configuration:

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd9:d72d:0353::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.0.0.1'
	option ip6assign '64'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option type 'bridge'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'
	option type 'bridge'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'
	option ar8xxx_mib_type '0'
	option ar8xxx_mib_poll_interval '500'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

cat /etc/config/wireless
config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ar934x_wmac'
	option htmode 'HT20'
	option txpower '20'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OKEYDOKEY'
	option network 'wan wan6'
	option key 'sorryIforgot'
	option wmm '0'
	option encryption 'psk2'
	option ieee80211w '2'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'
	list server '10.0.0.1#5353'

cat /etc/config/dhcp

config dhcp 'lan'
	option interface 'lan'
	option dhcpv6 'server'
	option ra 'server'
	option start '2'
	option limit '21'
	option ra_management '1'
	option leasetime '300s'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config host
	option mac 'yesofcourse'
	option leasetime '900s'
	option dns '1'
	option name 'yesofcourse'
	option ip '10.0.0.4'

config host
	option mac 'yesofcourse'
	option leasetime '900s'
	option dns '1'
	option name 'yesofcourse'
	option ip '10.0.0.5'

config host
	option mac 'yesofcourse'
	option leasetime '900s'
	option dns '1'
	option name 'yesofcourse'
	option ip '10.0.0.6'

config host
	option mac 'yesofcourse'
	option leasetime '900s'
	option dns '1'
	option name 'yesofcourse'
	option ip '10.0.0.7'

config host
	option mac 'yesofcourse'
	option leasetime '900s'
	option dns '1'
	option hostid 'yesofcourse'
	option name 'yesofcourse'
	option ip '10.0.0.8'

config host
	option mac 'yesofcourse'
	option leasetime '900s'
	option dns '1'
	option hostid 'yesofcourse'
	option name 'yesofcourse'
	option ip 'yesofcourse'

config host
	option mac 'yesofcourse'
	option leasetime '900s'
	option dns '1'
	option hostid 'yesofcourse'
	option ip '10.0.0.10'
	option name 'yesofcourse'

config host
	option mac 'yesofcourse'
	option leasetime '900s'
	option dns '1'
	option hostid 'yesofcourse'
	option ip '10.0.0.11'
	option name 'yesofcourse'

config host
	option mac 'yesofcourse'
	option name 'yesofcourse'
	option dns '1'
	option ip '10.0.0.12'
	option leasetime '900s'

config host
	option mac 'yesofcourse'
	option dns '1'
	option hostid 'yesofcourse'
	option name 'yesofcourse'
	option ip '10.0.0.13'
	option leasetime '900s'

config host
	option mac 'yesofcourse'
	option leasetime '900s'
	option dns '1'
	option hostid 'yesofcourse'
	option name 'yesofcourse'
	option ip '10.0.0.14'

config host
	option mac 'yesofcourse'
	option leasetime '900s'
	option dns '1'
	option hostid ''
	option name 'yesofcourse'
	option ip '10.0.0.15'

config host
	option mac 'yesofcourse'
	option leasetime '0'
	option dns '1'
	option name 'Repeat'
	option ip '10.0.0.2'

cat /etc/config/firewall
config rule
	option name 'PCtrl_Reject'
	option utc_time '1'
	option dest 'wan'
	option src 'lan'
list src_mac '7B:86:31'
	list src_mac '00::F6:E1'
	list src_mac '00:251'
	list src_mac '00:26:BB:0D:99:11'
	list src_mac '3C:E:91:EC:51'
	list src_mac 'A4:1A1'
	list src_mac 'B88:51'
	list src_mac 'B:24:11'
	option target 'REJECT'
	list proto 'all'

config rule
	list proto 'all'
	option utc_time '1'
	option weekdays 'Mon Tue Thu Fri'
	option src 'lan'
	option name 'Pctrl_Accept'
	option stop_time '17:00:00'
	option dest 'wan'
	option start_time '16:00:00'
	option target 'ACCEPT'
	list src_mac '7B:86:31'
	list src_mac '00::F6:E1'
	list src_mac '00:251'
	list src_mac '00:26:BB:0D:99:11'
	list src_mac '3C:E:91:EC:51'
	list src_mac 'A4:1A1'
	list src_mac 'B88:51'
	list src_mac 'B:24:11'

config rule
	list proto 'all'
	option utc_time '1'
	option weekdays 'Wed'
	option src 'lan'
	option name 'Pctrl_Accept_Wend'
	option stop_time '18:00:00'
	option dest 'wan'
	option start_time '15:00:00'
	option target 'ACCEPT'
list src_mac '7B:86:31'
	list src_mac '00::F6:E1'
	list src_mac '00:251'
	list src_mac '00:26:BB:0D:99:11'
	list src_mac '3C:E:91:EC:51'
	list src_mac 'A4:1A1'
	list src_mac 'B88:51'
	list src_mac 'B:24:11'

config rule
	option utc_time '1'
	option weekdays 'Sun Sat'
	option src 'lan'
	option stop_time '12:00:00'
	option dest 'wan'
	option start_time '10:00:00'
	option target 'ACCEPT'
	list src_mac '7B:86:31'
	list src_mac '00::F6:E1'
	list src_mac '00:251'
	list src_mac '00:26:BB:0D:99:11'
	list src_mac '3C:E:91:EC:51'
	list src_mac 'A4:1A1'
	list src_mac 'B88:51'
	list src_mac 'B:24:11'
	option name 'Pctrl_Weekends-am'
	list proto 'all'

config rule
	option weekdays 'Sun Sat'
	option src 'lan'
	option name 'Pctrl_Weekends_pm'
	option stop_time '18:00:00'
	option dest 'wan'
	option start_time '17:00:00'
	option target 'ACCEPT'
	list src_mac '7B:86:31'
	list src_mac '00::F6:E1'
	list src_mac '00:251'
	list src_mac '00:26:BB:0D:99:11'
	list src_mac '3C:E:91:EC:51'
	list src_mac 'A4:1A1'
	list src_mac 'B88:51'
	list src_mac 'B:24:11'
	list proto 'all'
	option utc_time '1'

I am was on and still I'm on: 9.07.7 r11306-c4a6851c72
I meant I did an opkg update. Sorry.

I changed it to 'lan' but same problem. Any other ideas?

meanwhile, I get authentication as show in systemlog:

Mon Apr  4 22:05:37 2022 daemon.info hostapd: wlan0: STA 00:1b:fc: authenticated

opkg update or opkg upgrade?

opkg update

Looks like you didn't commit the change to lan as requested.

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OKEYDOKEY'
	option network 'lan'
	option key 'sorryIforgot'
	option wmm '0'
	option encryption 'psk2'
	option ieee80211w '2'

Pop that in,
uci commit
/etc/init.d/network restart

And for crying out loud don't show the whole world your passwords. :face_with_peeking_eye: unless your forgot!

I have done this. Same problem.
I must mention that I had changed the USB stick to which I had /overlay
But I doubt this an issue. I may be wrong.

I have gone to: /overlay/upper/etc/confi
and opened the 'network' file and there I did not see wifi or wlan0, etc. Is this an issue?

this is what's in that file:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix ':d72d:0353::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '10.0.0.1'
        option ip6assign '64'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option type 'bridge'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'
        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option ar8xxx_mib_type '0'
        option ar8xxx_mib_poll_interval '500'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

So you made a vlan for the radio?
I hate questioning this but I'ts hard to tell from your .....

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

What's bogus ~ you pasted in ~ or a misconfiguration.

I clueless.

I have done a new "cat /etc/config/wireless"

root@MariSol:/overlay/upper/etc/config# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ar934x_wmac'
	option txpower '20'
	option channel '11'
	option htmode 'HT20'
	option country 'DE'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Sun.Sea'
	option network 'lan'
	option key 'interesting'
	option wmm '0'
	option encryption 'psk2'
	option ieee80211w '2'

Yes, the issue is you are posting your comments and not reading and learning.

If you have got really nothing better to do ,.,, I truly suggest you Perform Reset.

Start from scratch and learn / repetition is the key to learning.
Making / repeating the same failure won't change the outcome positively.
Happy Flashing.

not sure about your comment. you asked I did a task, which I reported as done, but the problem persists.

Couple of things -

This should be -

option wmm '1'

As the message displayed for this setting in the wireless config screen states -

"Some wireless drivers do not fully support 802.11w"

I would disable it for testing.