Strange Wifi behavior (5Ghz) on wrt1200 ac v2

Hey all,

so I have my wrt1200ac set up with 18.06 and everything was working fine until today. Most of my devices were connected on the 5Ghz radio.

Suddenly the 5Ghz band stopped working, no clients are associated, the wifi (wrt) won't show up.

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'VHT80'
	option legacy_rates '1'
	option country 'ET'
	option channel '120'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr '62:38:e0:db:08:50'
	option encryption 'psk2'
	option key 'xxx'
	option ssid 'wrt'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option legacy_rates '1'
	option htmode 'HT40'
	option channel '3'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr '62:38:e0:db:08:4f'
	option encryption 'psk2'
	option ssid 'repeat'
	option wds '1'
	option key 'xxx'

config wifi-iface0    
	option device 'radio1'
	option mode 'ap'
	option ssid 'guest'
	option network 'guest'
	option encryption 'psk2'
	option key 'xxx'
	option isolate '1'
	option disabled '1'

and /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd79:762f:c3cd::/48'    

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'    

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
    	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'    

config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	option type 'bridge'

Any ideas on what might be going on? Thanks to all for the great support