Strange problem with getting IP from DHCP for one device only

Hi!

I’m new to OpenWRT, and looking for some help with WiFi connection debug.

Have couple devices connected succesfully to Router. All of them(laptop, phone, two Sonos speakers) have their IP adresess from bultin DHCP server.

During connection of third Sonos speaker there is problem in Sonos App.
I’ve checked via SSH logs and have there:

Wed Nov  1 18:18:00 2023 cron.err crond[2271]: USER admin pid 24096 cmd /etc/init.d/sysntpd restart
Wed Nov  1 18:18:04 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c IEEE 802.11: authenticated
Wed Nov  1 18:18:04 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c IEEE 802.11: associated (aid 5)
Wed Nov  1 18:18:04 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c WPA: sending 1/4 msg of 4-Way Handshake
Wed Nov  1 18:18:04 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c WPA: received EAPOL-Key frame (2/4 Pairwise)
Wed Nov  1 18:18:04 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c WPA: sending 3/4 msg of 4-Way Handshake
Wed Nov  1 18:18:04 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c WPA: received EAPOL-Key frame (4/4 Pairwise)
Wed Nov  1 18:18:04 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c RADIUS: starting accounting session B37D453302F70EAE
Wed Nov  1 18:18:04 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c WPA: pairwise key handshake completed (RSN)
Wed Nov  1 18:18:04 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c IEEE 802.11: disassociated
Wed Nov  1 18:18:11 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c IEEE 802.11: authenticated
Wed Nov  1 18:18:11 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c IEEE 802.11: associated (aid 5)
Wed Nov  1 18:18:11 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c WPA: sending 1/4 msg of 4-Way Handshake
Wed Nov  1 18:18:11 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c WPA: received EAPOL-Key frame (2/4 Pairwise)
Wed Nov  1 18:18:11 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c WPA: sending 3/4 msg of 4-Way Handshake
Wed Nov  1 18:18:11 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c WPA: received EAPOL-Key frame (4/4 Pairwise)
Wed Nov  1 18:18:11 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c RADIUS: starting accounting session 4EDFA5EC18836733
Wed Nov  1 18:18:11 2023 daemon.info hostapd: ath0: STA f0:f6:c1:0d:13:4c WPA: pairwise key handshake completed (RSN)

Normally aftet that part there should be an info about DHCPDISCOVER and so on… ending by sucesfull IP lease.
There wasn’t anything like that, just disconnect of the device.

This third speaker is working fine via Ethernet cable… and fine via any other WiFi Router :slight_smile:

What I can check in OpenWRT to see more info about connection process for this device?

Let's see your complete config:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

@psherman My config from provided commands:

admin@PG5298B:~# ubus call system board
{
	"kernel": "4.14.275",
	"hostname": "PG5298B",
	"system": "ARMv8 Processor rev 0",
	"model": "PG5298B",
	"board_name": "kaon,pg5298",
	"release": {
		"distribution": "OpenWrt",
		"version": "4.0.7",
		"revision": "r0+16327-a77ea2f",
		"target": "CA82xx/cortex-a55",
		"description": "OpenWrt 4.0.7 15dd14a1"
	},
	"gponsn": "KAON1000025E",
	"buildtime": "230426_1715"
}
admin@PG5298B:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option defaultroute_table '0'
	option cwmp_ip_int_instance '1'
	option cwmp_ipv4_instance '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option defaultroute_table '0'
	option cwmp_ip_int_instance '2'
	option cwmp_ipv4_instance '1'

config interface 'wan'
	option device 'eth0'
	option defaultroute_table '0'
	option cwmp_ip_int_instance '3'
	option cwmp_ipv4_instance '1'

config device 'HSIdev'
	option type '8021q'
	option ifname 'eth0'
	option vid '35'
	option priority '0'
	option egress_qos_mapping '0:0'
	option name 'eth0.35'
	option macaddr '18:34:AF:BD:19:85'

config interface 'HSI'
	option proto 'dhcp'
	option ifname 'eth0.35'
	option device 'eth0.35'
	option disabled '0'
	option multiwan '1'
	option nat '1'
	option defaultroute_table '1'
	option defaultroute '1'
	option dns_to_lan '0'
	option cwmp_ip_int_instance '4'
	option cwmp_ipv4_instance '1'

config rule 'default'
	option lookup 'HSI'
	option priority '80000'

admin@PG5298B:~# cat /etc/config/wireless

config wifi-device 'wifi0'
	option type 'qcawificfg80211'
	option channel 'auto'
	option hwmode '11a'
	option htmode 'HE160'
	option country 'PL'
	option txchainmask '15'
	option rxchainmask '15'
	option beacon_int '100'
	option he_ulmumimo '1'
	option he_dlofdma '1'
	option he_dlofdma_bf '1'
	option he_ulofdma '1'
	option txpower '17'
	option txbf '1'
	option use_obss_dyn_bw '0'
	option bandsteering '0'
	option bandsteering_debug '0'
	option easymesh '0'
	option band '5G_11AX'
	option stbc 'false'
	option cwmp_radio_instance '1'
	option disabled '0'
	option macaddr '18:34:af:bd:19:8a'

config wifi-iface 'default_wifi0'
	option device 'wifi0'
	option ifname 'ath0'
	option mode 'ap'
	option encryption 'psk2'
	option isolate '0'
	option hidden '0'
	option wmf '1'
	option wmm '1'
	option wmm_no_ack '0'
	option wmm_apsd '1'
	option wmm_ap_ac_be '4 6 3 0 - 0'
	option wmm_ap_ac_bk '4 10 7 0 - 0'
	option wmm_ap_ac_vi '3 4 1 6016 - 0'
	option wmm_ap_ac_vo '2 3 1 6016 - 0'
	option wmm_sta_ac_be '4 10 3 0 0 -'
	option wmm_sta_ac_bk '4 10 7 0 0 -'
	option wmm_sta_ac_vi '3 4 2 3008 0 -'
	option pmf '1'
	option cwmp_ssid_instance '1'
	option cwmp_access_pt_instance '1'
	option disabled '0'
	option wps_pbc '1'
	option cactimeout '60'
	option ssid 'PLAY_Swiatlowod_1984_5G'
	option key 'XXXX'

config wifi-iface 'guest_wifi0_1'
	option device 'wifi0'
	option ifname 'ath01'
	option mode 'ap'
	option encryption 'psk2'
	option isolate '0'
	option hidden '0'
	option pmf '1'
	option cwmp_ssid_instance '3'
	option cwmp_access_pt_instance '3'
	option disabled '1'
	option ssid 'PLAY_Swiatlowod_1984_5G_Guest'
	option key 'XXXXX'

config wifi-device 'wifi1'
	option type 'qcawificfg80211'
	option hwmode '11g'
	option cwmp_radio_instance '2'
	option country 'PL'
	option txchainmask '15'
	option rxchainmask '15'
	option beacon_int '100'
	option he_ulmumimo '1'
	option he_dlofdma '1'
	option he_dlofdma_bf '1'
	option he_ulofdma '1'
	option txpower '17'
	option txbf '1'
	option use_obss_dyn_bw '1'
	option bandsteering '0'
	option bandsteering_debug '0'
	option easymesh '0'
	option band '2G_11NG'
	option stbc 'false'
	option disabled '0'
	option macaddr '18:34:af:bd:19:8b'
	option channel 'auto'
	option htmode 'HE40'

config wifi-iface 'default_wifi1'
	option device 'wifi1'
	option ifname 'ath1'
	option mode 'ap'
	option encryption 'psk2'
	option isolate '0'
	option hidden '0'
	option wmf '1'
	option wmm '1'
	option wmm_no_ack '0'
	option wmm_apsd '1'
	option wmm_ap_ac_be '4 6 3 0 - 0'
	option wmm_ap_ac_bk '4 10 7 0 - 0'
	option wmm_ap_ac_vi '3 4 1 6016 - 0'
	option wmm_ap_ac_vo '2 3 1 6016 - 0'
	option wmm_sta_ac_be '4 10 3 0 0 -'
	option wmm_sta_ac_bk '4 10 7 0 0 -'
	option wmm_sta_ac_vi '3 4 2 3008 0 -'
	option pmf '1'
	option cwmp_ssid_instance '2'
	option cwmp_access_pt_instance '2'
	option wps_pbc '1'
	option disabled '0'
	option ssid 'PLAY_Swiatlowod_1984'
	option key 'XXXX'

config wifi-iface 'guest_wifi1_1'
	option device 'wifi1'
	option ifname 'ath11'
	option mode 'ap'
	option encryption 'psk2'
	option isolate '0'
	option hidden '0'
	option pmf '1'
	option cwmp_ssid_instance '4'
	option cwmp_access_pt_instance '4'
	option disabled '1'
	option ssid 'PLAY_Swiatlowod_1984_Guest'
	option key 'XXXXX'

admin@PG5298B:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option cwmp_dhcpv4servpool_instance '1'
	option cwmp_dhcpv6servpool_instance '1'
	option cwmp_RouterAdvertisement_InterfaceSetting_instance '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	option cwmp_dhcpv4servpool_instance '2'
	option cwmp_RouterAdvertisement_InterfaceSetting_instance '2'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

admin@PG5298B:~# cat /etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'DROP'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone 'lan'
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone 'wan'
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'HSI'
	option cwmp_natiface_instance '1'

config zone 'mgmt'
	option name 'mgmt'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'
	option enabled '1'
	option cwmp_FirewallChainRule_instance '1'

config rule
	option name 'Allow-DHCP-Renew-Mgmt'
	option src 'mgmt'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'
	option enabled '1'
	option cwmp_FirewallChainRule_instance '2'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '3'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '4'

config rule
	option name 'Allow-DHCPv6-WAN'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '5'

config rule
	option name 'Allow-DHCPv6-WAN-Mgmt'
	option src 'mgmt'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '6'

config rule
	option name 'Allow-MLD-WAN'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '7'

config rule
	option name 'Allow-MLD-WAN-Mgmt'
	option src 'mgmt'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '8'

config rule
	option name 'Allow-ICMPv6-Input-WAN'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '9'

config rule
	option name 'Allow-ICMPv6-Input-WAN-Mgmt'
	option src 'mgmt'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '10'

config rule
	option name 'Allow-ICMPv6-Forward-WAN'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '11'

config rule
	option name 'Allow-ICMPv6-Forward-WAN-Mgmt'
	option src 'mgmt'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '12'

config rule
	option name 'Allow-IPSec-ESP-WAN'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '13'

config rule
	option name 'Allow-IPSec-ESP-WAN-Mgmt'
	option src 'mgmt'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '14'

config rule
	option name 'Allow-ISAKMP-WAN'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '15'

config rule
	option name 'Allow-ISAKMP-WAN-Mgmt'
	option src 'mgmt'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'
	list network 'mgmt'
	option cwmp_FirewallChainRule_instance '16'

config include
	option path '/etc/firewall.user'
	option reload '1'

config rule
	option name 'Access-SSH-WAN'
	option src 'wan'
	option proto 'tcp'
	option dest_port '22'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '17'

config rule
	option name 'Access-HTTP-WAN'
	option src 'wan'
	option proto 'tcp'
	option dest_port '80'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '18'

config rule
	option name 'Access-HTTPS-WAN'
	option src 'wan'
	option proto 'tcp'
	option dest_port '443 8000'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '19'

config rule
	option name 'Access-ICMP-WAN'
	option src 'wan'
	option proto 'icmp'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '20'

config rule
	option name 'Access-TR69C-WAN'
	option src 'wan'
	option proto 'tcp'
	option dest_port '7547'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '1'
	option cwmp_FirewallChainRule_instance '21'

config rule
	option name 'Access-SSH-WAN-Mgmt'
	option src 'mgmt'
	option proto 'tcp'
	option dest_port '22'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '22'

config rule
	option name 'Access-HTTP-WAN-Mgmt'
	option src 'mgmt'
	option proto 'tcp'
	option dest_port '80'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '23'

config rule
	option name 'Access-HTTPS-WAN-Mgmt'
	option src 'mgmt'
	option proto 'tcp'
	option dest_port '443 8000'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '24'

config rule
	option name 'Access-ICMP-WAN-Mgmt'
	option src 'mgmt'
	option proto 'icmp'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '25'

config rule
	option name 'Access-TR69C-WAN-Mgmt'
	option src 'mgmt'
	option proto 'tcp'
	option dest_port '7547'
	option family 'ipv4'
	option target 'ACCEPT'
	option enabled '1'
	option cwmp_FirewallChainRule_instance '26'

config rule
	option name 'Access-SSH-LAN'
	option src 'lan'
	option proto 'tcp'
	option dest_port '22'
	option family 'ipv4'
	option target 'DROP'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '27'

config rule
	option name 'Access-HTTP-LAN'
	option src 'lan'
	option proto 'tcp'
	option dest_port '80'
	option family 'ipv4'
	option target 'DROP'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '28'

config rule
	option name 'Access-HTTPS-LAN'
	option src 'lan'
	option proto 'tcp'
	option dest_port '443'
	option family 'ipv4'
	option target 'DROP'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '29'

config rule
	option name 'Access-ICMP-LAN'
	option src 'lan'
	option proto 'icmp'
	option family 'ipv4'
	option target 'DROP'
	option enabled '0'
	option cwmp_FirewallChainRule_instance '30'

config include 'intaccess'
	option path '/etc/firewall.intaccess'
	option reload '1'

config include 'broadcom'
	option path '/etc/firewall.broadcom'
	option enabled '1'

config zone 'guest'
	option name 'guest'
	option network 'guest'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'

config forwarding 'guest_wan'
	option src 'guest'
	option dest 'wan'

config rule 'guest_to_lan'
	option src 'guest'
	option dest 'lan'
	option proto 'all'
	option target 'REJECT'
	option cwmp_FirewallChainRule_instance '31'

config rule 'lan_to_guest'
	option src 'lan'
	option dest 'guest'
	option proto 'all'
	option target 'REJECT'
	option cwmp_FirewallChainRule_instance '32'

config rule 'guest_dns'
	option name 'Allow-DNS-Guest'
	option src 'guest'
	option dest_port '53'
	option proto 'tcp udp'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '33'

config rule 'guest_dhcp'
	option name 'Allow-DHCP-Guest'
	option src 'guest'
	option dest_port '67'
	option family 'ipv4'
	option proto 'udp'
	option target 'ACCEPT'
	option cwmp_FirewallChainRule_instance '34'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'

config include 'conndevd'
	option path '/etc/firewall.conndevd'
	option enabled '1'

config include 'devquota'
	option path '/etc/firewall.devquota'
	option enabled '1'
	option reload '1'

config include 'sdns'
	option path '/etc/firewall.sdns'
	option enabled '1'

config include 'appblock'
	option path '/etc/firewall.appblock'
	option enabled '1'
	option reload '1'

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

I've checked on Kaon page and it states it is normal OpenWRT software.
Please show me debug path for this kind of situation :slight_smile:

It's not. Official OpenWRT doesn't have support for the device you're using, therefore Kaon have modified the software. We don't know what changes they have made or how that might alter how other parts of the software function.

Your starting point is to pursue it with Kaon.

1 Like

Ok, understand will talk to KAON.
Last question, after digging through internet I've found that this problem is generated by DHCP Offer as Unicast/DHCP Proxy function.
Where I can find config files for DHCP Proxy Settings?

In a normal OpenWrt installation, you wouldn't be looking for that... the only thing would be in the /etc/config/dhcp file.

This is yet another question for 'kaon'.

Also, yet another reason that we know that the fimrware you are running is not even remotely related to the official OpenWrt project:

^^^ This version has never existed.

2 Likes