Strange opkg/wget behavior and disappearing packages

I've recently (like yesterday) started working with openwrt ( I am currently using dd-wrt)

I have 2 tp-link a6's (not the ones with dd-wrt, these are new), so I'm using the latest snapshot to gain support.
(I looked at the release images, but from what I could see from the names, it doesn't incorporate the latest changes)

So I've encountered 2 rather strange problems....

Issue 1

While running opkg update was fine in the beginning, but it times out now.

So, I tested it with wget via ssh, sure enough if I do


it times out....


if I do...


it works....

This happens on both routers. This one leaves me totally worked in the morning under the same network setup, now in the afternoon it does not,
with no changes at all, just a couple reboots because I had to physically move them.

I should point out that a laptop connected to either router can download the package manifests,

EDIT additionally, I wiped out one of the routers (firstboot) and now it runs ok...but we'll see for how long? Installed luci....

EDIT already stopped working after about 90 minutes

My second issue it on one of the routers, installed packages have disappeared. Like luci just decided to be gone, no trace, no service entries, nada.

The configs I used luci concerning network, etc are still there, it just is gone, along with anything else I installed.

And, no, I didn't do a sys upgrade in the meantime and all actually configuratioj done by me is there, just not even the libraries related to stuff I installed (like wavemon...libncurses) is there.

Hi @PetraKelly - welcome to OpenWrt and to the community!

I don't think anyone will be able to help you directly troubleshoot yet since there isn't quite enough detail about what you've done and what specifically is failing to work.

It appears your device is supported only by snapshots at this point.
With that in mind...

It is important to know that snapshots are not always stable. Generally they are pretty reliable, but there can be critical bugs since it is, by definition, a work in progress. Sometimes those bugs are generic, other times they may be device specific. Obviously not every issue is a bug (it could be configuration mistake, for example), but it is always important to know what you've installed/changed/configured to be able to track these things down.

Also, snapshots are moving targets. You may find that you will be unable to install new packages as little as a few hours after you download the snapshot build. This means that you will want to install everything of interest right away, or keep a local copy of the repo/source code from that build on your computer so you can install packages after the fact. Or, flash with the latest new snapshot and install at that point.

Now, as it relates to your issues, can you provide a details about how you are connecting the router(s) to the internet -- is it a direct connection to a cable/dsl modem or fiber ONT (and is the upstream device in bridge mode)? Or are you connecting to another router? What changes have you made relative to the default configuration (often it is best to post any config files that you have changed)? And what packages have you installed (if any) beyond the default install.

And other than the issue with opkg update failing (could you actually provide the specific output from this command) and the wget command timing out when you try to download the .gz file, are there any other things that are not working or other symptoms?

1 Like

Thank You for your reply...

This is the convoluted setup...haven't had anything like this since the Gated project lol...

The basic (TP* marks the devices in question...) read further for other descriptions..

<-> wired
<+> wireless

Verizon<->Verizon Router<->Buffalo<+>Cisco<->TP1<+>TP2

This is in a test setup, so one router (the AP) is connected to my normal network.

The other (client) is connected to my laptop.

It might help if I explain the setup this is supposed to upgrade...

The AP (connected to my company's network) is an early Buffalo pre300N, and a Cisco/Linksys E2500 running dd-wrt is in client mode for years and years. The setup is simplistic, one runs in AP mode, the other in bridged client mode (as defined by dd-wrt's definition) and just bridges 2 wired networks, and in addition the buffalo can serve laptops or what not.

As I went thru your documentation (erms, to be honest, it could use some help, please don't take offense, I'm famous for not documenting anything...what directories are the backups in? heh damn if I have the time to write it down lol) it seemed using a WDS setup would be the easiest (although I have not liked WDS for what I want to do in the past, because of the wired traffic repeating over wifi for no reason is what I read).

That said (while I will probably try a non-wds config...I don't need roaming at all, just one as a bridged client) it does work for the wired clients attached to either router. This is just strange behavior, Outside of your docs, I haven't done anything weird, just following them,

The disappearing packages I'm just going to forget for right now, thats pretty minor to me actually. 3 commands and luci is up and long as the frist command works lol (yes, I am thinking of bad nram as possible, but I'll need to really test this out)

I know I'm using snapshots, but I have no choice, but yes I know things might not work at all, but I'd assume you'd like to hear about.

Again the wget tests are just nuts,,,,something about it is crazy familiar when I was a sysadmin but I can't remember


So it still isn't really clear what you are trying to do and how things are configured (i.e. your overall network topology, how you have configured the OpenWrt routers, and so on). As far as WDS, that is not recommended if you can avoid it because it has a significant performance penalty among other things. And typically, WDS implementations are vendor or firmware specific, so you need to stay within a single platform

Anyway, if you have specific questions or issues, probably best to open new threads (one at a time) to address them. Always best to start simple and build from there. Make sure that you provide full context about the network topology and configuration of the OpenWrt setup so that people can help (otherwise it is only wild speculation).

EDIT: As @jow states in the comment following this one, WDS doesn't inherently degrade performance assuming there are 2 (+) radios in the device(s) such that one of the radios can be dedicated to the WDS/uplink while the other accepts clients.

That statement is not entirely true. A simple 4addr client used for bridging has no more performance penalty than a simple wireless station. Also using WDS with multi-radio devices has no performance penalty either. If you repeat a signal on the same radio, means having both the AP and the client on the same phy, then you'll see decreased performance, but that is not due to using WDS but due to running multiple vifs on the same phy.

1 Like

OK, well for some reason, it didn't seem like the best way to do a point to point bridge with openwrt was the way I did it with dd-wrt (and that's not even the main issue I was raising, refer back to my initial post regarding how wget behaves), the wds docs seemd the most straight forward for what I wanted.

So I'll relfash (don't want some silly thing I tried to be lingering) and config for straight AP and client.

As I said, I had no problems with network connectivity, only the opkg/wget issues. If going away from WDS will solve them, then I'm fine with testing that out, and more faithfully replicate my current setup