Stop OpenWrt from advertising itself as a DNS6-server

How do I stop OpenWRT from advertising itself as a DNS6-server? Nothing I do seems to work, it insists on advertising itself as a DNS6-server on a IPv6 link-local address. The router is not serving DHCP, it's not supposed to be serving DNS, it's only supposed to handle routing. I already have a separate router that handles DHCP and DNS and all that and I don't want my OpenWRT-routers messing with that.

I have tried setting the OpenWRT-routers to only listen on lo - interface, I have disabled IPv6 router-advertisements, I have tried disabling DNS via the following:

uci set dhcp.@dnsmasq[0].port="0"
uci commit dhcp
/etc/init.d/dnsmasq restart

But no, nothing I do seems to stop them from advertising themselves as DNS-servers on IPv6 link-local addresses.

I just stumbled upon something that works. No idea if this is the "correct" way of doing it, but I'll leave this here in case someone else wants this as well; I had to change the settings for the 'lan' interface in /etc/config/dhcp to:

config dhcp 'lan'
        option interface 'lan'
        option ignore '1'
1 Like

This is turning off both DHCPv4 and the RAs/DHCPv6.
If you don't want RAs (which carry also nameserver information) you can disable Router Advertisement Service and DHCPv6 Service.


Yes. I have a separate, PFsense-based, router that handles DHCP and DNS and I don't want OpenWRT messing around.

Just annoying that there is no way of disabling this stuff from Luci, would've taken me far less time to figure this out.

Network-Interfaces-Edit-DHCP Server-IPv6 Settings

That only shows up, if the interface is configured with a static IP. If you use e.g. DHCP, like I do, those options are not available.

That is correct. However if you add the interface with dhcp client protocol, the entry in dhcp configuration will be the following:

config dhcp 'test'
        option interface 'test'
        option ignore '1'

I suppose you just changed the protocol from static to dhcp before disabling them, right?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.