Stock flash with basic WiFi has high latency and drops

Equipment: Netgear Wax 202 & WAX 206. Pics in link at bottom for more details

My Problem:

I have tremendously high latency and drops just pinging the gateway, which is the router itself.

Details:

  • It it present on all wifi networks 2.4 and 5 ghz.
  • My WAX 206 is my "production" router running my wifi and other internet functions.
  • Neither 2.4 or 5 ghz channels are saturated.
  • I am not doing a tremendously large amount of network traffic. Often just web browsing.
  • I am not far from it at all and nothing is in between me and it.

Example 1: Connecting to WAX 206 and immediately pinging it. Low latency for a few seconds and then high ping times with a single drop. There are often windows where 4 or 5 drops may happen several times within a few minutes.

Example 2: WAX 202 same process. Possibly slightly better? Hard to say though since it is sporadic or inconsistent.

Things I've checked/tried:

  • Rebooting.
  • No there aren't overlapped or saturated channels but I've tried different ones. I've tried changing the channel width as well.
  • I've changed the security settings (WPA2, WPA3 mixed, CCMP, etc).
  • I'm using the WAX 202 as a test. Upgrading to the new 23.05.3 made little to no difference on it.
  • Changing various power options on the router and my laptop made no difference.
  • On the WAX 202 I completely reset and reflashed it. The only thing I did was set a password, create a basic Wi-Fi network, and tie it to the LAN directly.
  • In the case of my WAX 202 I am about 1 ft from it with these ping times and the only thing connected is my laptop over Wi-Fi. It has no internet access physically.
  • Connecting to either via Ethernet has ping times of 1ms or less consistently
  • Pulling out 1/3rd of my hair
  • Praying to several deities

More details and pics: Reddit thread

Have you set the country code for your wifi network?

Yes, I have set it to US.

How are you testing the latency and drops?

  • What is the source device of the pings?
  • Is it the WAX 20x devices, or a device connected to the AP(s)?

Can you show a diagram of your network topology?

Have you verified that there are no such issues if you are wired?

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

I have some additional pics in the reddit thread if it helps.

I am pinging from my wireless laptop to the router.
There really isn't much of a diagram. In the case of my wax202 it's my laptop and the router, that's it.
For my wax206/production, it's connected to my ISP modem and the only other things are regular wireless clients.
I do not have these issues on wired connections.

I'll get back on the output.