Still problem with transmission?


I can't use transmission since 2 months, here some of my config, maybe someone could help me.?
No acces to transmision from web interface

Tue Mar 29 08:03:35 2022 user.notice transmission: Starting with 237080000 virt mem
Tue Mar 29 08:03:35 2022 user.err : jail: failed to load dependencies
Tue Mar 29 08:03:35 2022 daemon.err transmission-daemon[11543]: jail: failed to load dependencies

Also, I checked here ;

My config;

config transmission
	option config_overwrite '1'
	option user 'transmission'
	option group 'transmission'
	option mem_percentage '50'
	option nice '10'
	option alt_speed_enabled 'false'
	option alt_speed_time_enabled 'false'
	option bind_address_ipv4 ''
	option bind_address_ipv6 '::'
	option blocklist_enabled 'false'
	option cache_size_mb '2'
	option dht_enabled 'true'
	option download_queue_enabled 'true'
	option download_queue_size '4'
	option encryption '1'
	option idle_seeding_limit_enabled 'false'
	option incomplete_dir_enabled 'false'
	option lazy_bitfield_enabled 'true'
	option lpd_enabled 'false'
	option message_level '1'
	option peer_limit_global '240'
	option peer_limit_per_torrent '60'
	option peer_socket_tos 'default'
	option pex_enabled 'true'
	option port_forwarding_enabled 'true'
	option preallocation '1'
	option queue_stalled_enabled 'true'
	option queue_stalled_minutes '30'
	option ratio_limit_enabled 'false'
	option rename_partial_files 'true'
	option rpc_authentication_required 'false'
	option rpc_bind_address ''
	option rpc_enabled 'true'
	option rpc_host_whitelist_enabled 'false'
	option rpc_port '9091'
	option rpc_url '/transmission/'
	option scrape_paused_torrents_enabled 'true'
	option script_torrent_done_enabled 'false'
	option seed_queue_enabled 'false'
	option speed_limit_down_enabled 'false'
	option speed_limit_up_enabled 'false'
	option start_added_torrents 'true'
	option trash_original_torrent_files 'false'
	option umask '18'
	option upload_slots_per_torrent '14'
	option utp_enabled 'true'
	option scrape_paused_torrents 'true'
	option watch_dir_enabled 'false'
	option enabled '1'
	option download_dir '/mnt/sda1'
	option config_dir '/etc/config/transmission'
	option peer_port '50000'
	option peer_port_random_on_start 'false'
	option rpc_whitelist_enabled 'true'
	option rpc_whitelist ',*.*.*.*'

I tried with whitelist enable and disable...

what .... doesn't ..... work .... ?

1 Like

Oh sorry, forgot

No web interface,, no acces

and you're sure transmission's actually running ?

It is enabled, and I restarted it to be sure.
Or I need to do something else :wink:

It's been broken for months due to wolfssl libraries. Reverting to openssl libraries was the solution for me. Of course, YMMV...


1 Like

I use OpenSSL....

Maybe another bit torrent client would work?

That's not really an answer to the question...

1 Like

... if we have some problems with transmission since a months, maybe so

.... and I got it to work, w/o any issues, as you saw in the thread you linked to.

You're still not answering the question.

root@OpenWrt:~# /etc/init.d/transmission status

here my settings.json

"alt-speed-enabled": false,
"alt-speed-time-enabled": false,
"blocklist-enabled": false,
"download-queue-enabled": false,
"dht-enabled": true,
"encryption": 1,
"idle-seeding-limit-enabled": false,
"incomplete-dir-enabled": false,
"lazy-bitfield-enabled": true,
"lpd-enabled": false,
"message-level": 2,
"peer-limit-global": 240,
"peer-limit-per-torrent": 60,
"peer-port": 51413,
"peer-port-random-on-start": false,
"pex-enabled": true,
"port-forwarding-enabled": false,
"preallocation": 1,
"ratio-limit-enabled": false,
"rename-partial-files": true,
"rpc-authentication-required": false,
"rpc-enabled": true,
"rpc-port": 9091,
"rpc-whitelist-enabled": true,
"queue-stalled-enabled": false,
"scrape-paused-torrents-enabled": false,
"script-torrent-done-enabled": false,
"seed-queue-enabled": false,
"speed-limit-down-enabled": false,
"speed-limit-up": 40,
"speed-limit-up-enabled": true,
"start-added-torrents": false,
"trash-original-torrent-files": false,
"umask": 18,
"upload-slots-per-torrent": 14,
"utp-enabled": false,
"watch-dir-enabled": false,
"rpc-host-whitelist-enabled": false,
"bind-address-ipv4": "",
"bind-address-ipv6": "::",
"download-dir": "/mnt/sda1/",
"peer-socket-tos": "0",
"rpc-bind-address": "",
"rpc-whitelist": ",192.168.1.*",
"invalid-key": false