Status of WAC510 port

As pointed out by Chunkeey in your PR, I compiled and flashed a build without the ipq-wifi-netgear_wac510 device package and using the upstreamed boardfiles and haven't encounted any wifi releated regressions and seems safe to remove it.

	DEVICE_DTS_CONFIG := config@5
	BLOCKSIZE := 128k
	PAGESIZE := 2048
	DEVICE_PACKAGES := uboot-envtools

As far as I remember the local BDFs are newer then upstream ones.
There was a update to one of the radios.

1 Like

Only found your original PR and when it was added upstream.

Were they extracted from a newer factory firmware?

edit: found an update but seems to be based on the same upstreamed version:

PR has been merged to master.


I build the firmware on my local build server to test it with my WAC505.
Sadly, I got the same result as before: The AP reboots 2 times and returns with the netgear firmware :frowning:

At the first reboot I see NO network activity for a longer time ( checked with
tcpdump -n -i eth1 'ether host 08:02:8e:41:f1:cf'
on my local machine, where it is conncted to)

The only difference between WAC510 and WAC505 are the number of ethernet ports. The WAC505 has only one ethernet port...

I got a TTL UART adapter but I don't have the "special screw driver thing" for the funny screws now - I try to get one and open the case to connect the serial port do debug the boot process, but that could take a while...

Any idea why the build doesn' run?

1 Like

I think you might need to downgrade to an older official build to be able to flash from factory to OpenWRT as I recall @robimarko said something about Netgear changing firmware upgrade checks in more recent builds.

Its been a while since the last time I tried.
I can confirm that in 5.x FW they changed the archive format.
I think that in v3 flashing worked from the WEB UI


I checked it again with original fw V1.5.2.3, V3.1.0.12, V5.0.10.2 flashing the snapshot build from today via web ui - All with the same result.
AP reboots, the power LED get on (orange), after a few seconds the power LED is going off for one second and gets on again. This repeats 4 times and then the AP returns with the original fw.

It seems the WAC510 build does not run on a WAC505 without modification.
I think I have to wait until the "special screw driver thing" arrives (sadly, it is announced for > Jun. 23. :frowning: ) and I can connect the UART to it.

btw - thanks for the great work and the support :slight_smile:

I added the techdata and device page now as well. Feedback welcome.

@tmomas Somehow them tables still show 'Nothing found'. Any idea?

1 Like


  • If the tables below contain “Nothing found”, it means that either
  1. filters are not set correctly. Most common reason for “Nothing found”: The dataentry does not contain a Version, but we are filtering here for version → Please edit this section and adjust the filters with the proper Brand, Model and Version. In case the dataentry does not contain a version, delete the line filter : Versions~. Just try, it's easy. The tables should then contain $something. If they do, delete this text and the <WRAP> that encloses it.
1 Like

I managed to open the WAC505 (!) now - But I didn't find any serial related things there.

This is an image of the board. I didn't see a photo of a WAC510 so I can't compare the layout. Any Idea?

Hm, that PCB indeed looks very different! Here from the WAC510 FCC internal photos.

UART header on left side where the bulky capacitor is. Maybe you are lucky and find it behind that big black tape?

I checked the things under the shielding tape also, I can't find anything related to a serial connector at all.

I see the board is completely different from the WAC510, so I have no idea how to make diagnostics without a serial connection...

I thought if netgear provides one firmware for WAC510 and WAC505, it will be easy to run the WAC510 build on the 505 but it's not :frowning:

Yeah, it looks like Netgear went to great lengths to further cost optimise that SKU. However, looking at the FCC filing the SoC as well as its UART header might be found on the back side. Have you checked?

1 Like

I can't beleave what I see...
If the plug on the lower left corner is the uart connector, the connector is accessible without opening anything. I will check that very quickly :smiley:

1 Like

Yes. It is the UART connector. 115200, 8N1
From left to right (rotation like the photo): GND, TX, 3,3V, RX.
Thanks a lot for the photo from the back side.

I will check the boot of the openwrt fw later :smiley:

1 Like

Console log from WAC505, when trying openwrt fw for WAC510:

Requesting system reboot
[  160.296951] reboot: Restartiî
Format: Log Type - Time(microsec) - Message - Optional Info
Log Type: B - Since Boot(Power On Reset),  D - Delta,  S - Statistic
S - Boot Config, 0x00000025
S - Reset status Config, 0x00000010
S - Core 0 Frequency, 0 MHz
B -       261 - PBL, Start
B -      1338 - bootable_media_detect_entry, Start
B -      2608 - bootable_media_detect_success, Start
B -      2622 - elf_loader_entry, Start
B -      4029 - auth_hash_seg_entry, Start
B -      6178 - auth_hash_seg_exit, Start
B -     74197 - elf_segs_hash_verify_entry, Start
B -    195986 - PBL, End
B -    196010 - SBL1, Start
B -    288028 - pm_device_init, Start
D -         7 - pm_device_init, Delta
B -    289519 - boot_flash_init, Start
D -     88426 - boot_flash_init, Delta
B -    382246 - boot_config_data_table_init, Start
D -     13920 - boot_config_data_table_init, Delta - (419 Bytes)
B -    398915 - clock_init, Start
D -      7576 - clock_init, Delta
B -    409928 - CDT version:2,Platform ID:8,Major ID:1,Minor ID:0,Subtype:1
B -    413341 - sbl1_ddr_set_params, Start
B -    418435 - cpr_init, Start
D -         2 - cpr_init, Delta
B -    422818 - Pre_DDR_clock_init, Start
D -         4 - Pre_DDR_clock_init, Delta
D -     13171 - sbl1_ddr_set_params, Delta
B -    436122 - pm_driver_init, Start
D -         2 - pm_driver_init, Delta
B -    506125 - sbl1_wait_for_ddr_training, Start
D -        28 - sbl1_wait_for_ddr_training, Delta
B -    521449 - Image Load, Start
D -    143734 - QSEE Image Loaded, Delta - (269176 Bytes)
B -    665609 - Image Load, Start
D -      2117 - SEC Image Loaded, Delta - (2048 Bytes)
B -    675752 - Image Load, Start
D -    181069 - APPSBL Image Loaded, Delta - (429220 Bytes)
B -    857217 - QSEE Execution, Start
D -        56 - QSEE Execution, Delta
B -    863418 - SBL1, End
D -    669518 - SBL1, Delta
S - Flash Throughput, 2061 KB/s  (701039 Bytes,  340016 us)
S - DDR Frequency, 672 MHz

U-Boot 2012.07-V1.5.1.0-01465-g84eccc7-dirty [local,local] (Feb 15 2017 - 02:11:18)

smem ram ptable found: ver: 1 len: 3
DRAM:  256 MiB
machid : 0x8010001
NAND:  ID = 9580f12c
Vendor = 2c
Device = f1
ONFI device found
SF NAND unsupported id:ff:ff:ff:ffSF: Unsupported manufacturer ff
ipq_spi: SPI Flash not found (bus/cs/speed/mode) = (0/0/48000000/0)
128 MiB
In:    serial
Out:   serial
Err:   serial
Product ID: WAC505
machid: 8010001
flash_type: 2
led_gpio: 22
Net:   MAC0 addr:8:2:8e:41:f1:cf
PHY ID1: 0x4d
PHY ID2: 0xd0b2
ipq40xx_ess_sw_init done
Hit any key to stop autoboot:  2  1  0 
Saving Environment to NAND...
Erasing Nand...
Erasing at 0x480000 --  25% complete.Erasing at 0x4a0000 --  50% complete.Erasing at 0x4c0000 --  75% complete.Erasing at 0x4e0000 -- 100% complete.
Writing to Nand... done
Boot count=1
Creating 1 MTD partitions on "nand0":
0x000000800000-0x000003c00000 : "mtd=0"
UBI: attaching mtd1 to ubi0
UBI: physical eraseblock size:   131072 bytes (128 KiB)
UBI: logical eraseblock size:    126976 bytes
UBI: smallest flash I/O unit:    2048
UBI: VID header offset:          2048 (aligned 2048)
UBI: data offset:                4096
UBI: volume 2 ("rootfs_data") re-sized from 9 to 350 LEBs
UBI: attached mtd1 to ubi0
UBI: MTD device name:            "mtd=0"
UBI: MTD device size:            52 MiB
UBI: number of good PEBs:        416
UBI: number of bad PEBs:         0
UBI: max. allowed volumes:       128
UBI: wear-leveling threshold:    4096
UBI: number of internal volumes: 1
UBI: number of user volumes:     3
UBI: available PEBs:             0
UBI: total number of reserved PEBs: 416
UBI: number of PEBs reserved for bad PEB handling: 4
UBI: max/mean erase counter: 1/0
Read 0 bytes from volume kernel to 84000000
No size specified -> Using max size (4063232)
Config not availabale

bootipq failed!!
resetting ...

This repeats 5 times until Boot count=5

Then it boots original from backup partition...

Looks like the nand chip is not recognized.

Have you tried just booting OpenWRT with the initramfs image using tftpboot?

If it depends on this message, this message is also printed with original netgear image.

I didn't try the initramfs yet, but I will check this next days :slight_smile:

1 Like