Static route not working to starlink gen3 dish (rectangular)

I've recently installed r20165-8a77adb048 on a dfrobot router carrier board with a raspberry pi cm4 module. This was an image that I built using instructions here (https://gist.github.com/ionspin/180437c1580f9a2a1c4f1e8d532b9f27). I also tried the image available on the dfrobot wiki (https://wiki.dfrobot.com/Compute_Module_4_IoT_Router_Board_Mini_SKU_DFR0767) but that image did not even respond on a serial console.

I've tried various settings to allow the lan to reach 192.168.100.1 (which is necessary for the starlink administrative interface). From reading, I understand this should be a very simple static route entry.
eg:

config route
	option interface 'wan'
	option target '192.168.100.1'
	option netmask '255.255.255.255'

however this doesn't allow a lan client to reach 192.168.100.1

I have also tried various permutations on this (eg 192.168.100.0/24) but none of them have worked.

I can ping 192.168.100.1 from the openwrt system itself, so I know that the wan network is connected properly.

Could this be a firewall rule getting in the way?

Thanks in advance for any assistance.

stopping the firewall doesn't change this behavior, so I am doubtful it is a firewall issue

root@OpenWrt:~# service firewall stop
root@OpenWrt:~# service firewall status
inactive

a traceroute from the lan client:

traceroute 192.168.100.1
traceroute to 192.168.100.1 (192.168.100.1), 64 hops max, 52 byte packets
 1  openwrt (192.168.1.1)  0.719 ms  0.187 ms  0.161 ms
 2  * * *
 3  * * *

it never completes.

I think this is more an issue of https://openwrt.org/docs/guide-user/network/wan/access.modem.through.nat - than for a static route.

This worked perfectly.

Thank you!!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.