Static IP lease config in /etc/config/dhcp works only for wired


I'm trying to set up a static IP for a couple of devices.

My /etc/config/network looks like the below. For the device TV-CABLE (which is connected with a cable to the router) it assigns the IP, and everything seems to work fine.

Device abc connects through WIFI and gets IP. But then I go to Network -> Wireless -> associated stations in LUCI, i see this - Host: abc.lan (

My goal here is to exclude this device from OpenVPN. for TV-CABLE, this is working fine already. For abc I have internet, but the VPN website confirms that I'm still going through the VPN - it didn't apply the exclude rule since the device has a different IP than in the rule.

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'TV-CABLE'
        option dns '1'
        option mac '50:56:BF:A7:EF:46'
        option ip ''
        option leasetime '1d'
        option tag 'novpn'

config host
        option dns '1'
        option mac '50:EB:71:59:C1:53'
        option ip ''
        option leasetime '1d'
        option name 'abc'
        option tag 'novpn'

config tag 'novpn'
        option dhcp_option '6,,'

You cannot assign a address on a network.


Hi eduperez,

Yes, indeed - that was a very silly typo on my end. Now it works perfectly. Thanks!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.