Static hosts not propogating after upgrade to 23.05

I updated from 22 to 23 today and so far the two new hosts that I gave out static IP's for are not resolving.

How can I diagnose issues like:

nslookup kestra.lan 192.168.1.1
Server:		192.168.1.1
Address:	192.168.1.1#53

** server can't find kestra.lan: NXDOMAIN

What steps can I do to debug the issue?

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

OMG just figured out the answer. I ssh'd, and looked at /etc/config/dhcp to see what the difference is between hosts I added before the upgrade and ones I added after, and the 'new' hosts did not have the line:
option dns '1'
..

Somehow that is not checked by default in v. 23. Wow.. it really should be .

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

Sorry, missed the 'editable' window for the post title! I'll get it next time

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.