Static DHCP lease not working

I have an issue with static DHCP lease. I tried adding one with the following steps:

  1. ssh my router
  2. vi /tmp/dhcp.leases, remove the line which refers to my raspberry pi at 192.168.1.180
  3. LuCi: Added an entry to Network > DHCP and DNS > Static leases >>> Server settings table
    pi3 | B8:27:EB:A2:53:89 | 192.168.11.133 | infinite | *none* | *none*
  4. ssh: vi /etc/config/dhcp, made sure this is there:
config host                                          
        option name 'pi3'           
        option dns '1'                      
        option mac 'b8:27:eb:a2:53:89'               
        option ip '192.168.11.133'    
        option leasetime 'infinite'
  1. Restarted my rpi, and while it is restarting, through ssh: /etc/init.d/network reload, uci commit dhcp and /etc/init.d/dnsmasq restart

Still, after the raspberry getting an IP, the LuCi Network > DHCP and DNS > Static leases >>> Active DHCP Leases table has this:

Hostname |  IPv4-Address |  MAC-Address |  Lease time remaining
pi3 |  192.168.1.180 |  B8:27:EB:A2:53:89 |  11h 53m 19s

And also ip a s on the raspi shows the .180 ip address.
What am I doing wrong?

I think it is obvious.

Oh Jesus. I have been looking into this for 2 days on and off now.

It has happened to all of us :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.