State of TP-Link Archer C7v2|v5 in 2023

Yeah, if you want your full bandwidth. Two options if you use the C7, set your SQM speed threshold down to 100 or so. Or, if you have an asymmetric connection (I used to have a 300/30mbit one) you can try SQM'ing the upload, and set 0 for the download, which disables it. In my case the 30mbit upload was easy for the C7, and it helped quite a lot of the Bloat. This wont help if you have a 200/200 connection, though.

If you do, you need to find a more powerful router, or accept that you'll have to cut your speed way down.

Just tried installing Catfriend image on my C7 v5 via tftp and my router winds up in a bootloop. I can install the factory file and it flashes fine, sysupgrade also winds up in a boot loop. Any suggestions?

Try a serial cable to capture console output while it bootloops . It may be a previously wrong product/vendor id in the flash.

Thanks for the quick response, I don't have a serial cable to hand, where is the product/vendor id stored? Is it the header? Just wondering if there's some quick hex editing i can do by comparing the file that will flash with the one that won't. It copies fine via tftp but then immediately resets itself when the file has copied rather than attempting to install. Just tried tp-link's stock as well, the only file that will install is the factory version of openwrt.

EDIT : this one -

I've posted the hex numbers previously in some unbrick archer c7v2 thread.

Thanks again, in the end i restarted from the factory firmware that was working and have now got everything up and running. Just need to tweak a few things but roaming all seems to be working and both my 5ghz and 2.4 seem to be working well.

How is the stability of the 2.4 Ghz Wifi AP mode in the latest stable release 21.02.2?

Stable for me.


But non-CT or CT-smallbuffers?


1 Like

non ct because it supports batman-adv 802.11s mesh

1 Like

Is there a guide on installing the watchdog scripts?

I've got a V3 (which I understand is essentially the same as the V2 with a different antenna configuration) and I'm using the official 21.02.2 build. Already switched to the non-CT for the 10k and applied the memory limit startup script but I still end up with the 2.4Ghz speed dropping (download to about 1/2 of the usual while upload is a crawl) which is fixed by a rescan, so I think the watchdog would help that. I've also had the 5Ghz "disappear" so I'm hoping the watchdog might catch that as well.

I switched to OpenWRT because the WiFi would get wonky on the original firmware and I hoped it would help stability, but I think it may be worse.

1 Like

@Catfriend1 I'm planning to use your scripts to build my own image of 21.02.2. Mine will include usb storage, dawn, diffutils, wireguard, and nut. Basically all the things I use regularly.

I find it interesting that you don't seem to mention or care about dawn...

I have 4 v2's. I use 2 of them in WPS mode to extend the network to places where I havn't run cable to yet.

Anyways just posting to keep the thread alive. Thanks for all your contributions.

1 Like

I read the dawn dev thread a while ago but didn't get up to try to implement it in my environment to give it a shot. While reading I was so unsure if dawn is supported with non-ct drivers (?) . Well, out of curiosity: I'd love to see a dawn Archer c7v2/5 example config if you get that running :-).

1 Like

@Catfriend1, any plan to update this in 2022?

Sure, 21.02.1-stable is running fine for me without any hiccups. That was just why I didn't feel the need to go to 21.02.2 or 21.02.3 (or even the 22.x rc) . I've got 2.4 GHz and 5 GHz dumb AP uptime of more than 80 days on my Archers and counting without a problem - and I think that's the point where I slow down with updates. It's so beautiful they just finally /work/. If I'm ready and build a newer stable with ath10k-non-ct , I'll post it here for you.

21.02.3 has been running well on my v2.

22.03.0-rc1 did not.

1 Like

Good to know RE 22.03.0-rc1. Want to expand on that a bit more? What didn't work?

See the release announcement thread.

21.02.1 is running very well on my v2 and v5. Looking forward to 22.x versions if and when you ready them :slightly_smiling_face:

1 Like