Start dockerd after boot

any solution to start dockerd automatically after boot ?

placing /etc/init.d/dockerd start & in rc.local did not help

all service has an enable parameter, which links the given service to startup process. always use that. (parameter disable undo.)

1 Like

/etc/init.d/dockerd enable

clicked on enable in system / software / startup

the service still does not start after boot

Maybe you have some sort of race condition with another process/init script.

I had this before with docker and Adguard, rc.local and docker and also docker and lxc. Actually with lxc there was a cgroup error/issue…

Did you take a look at the system log? Most of the time you will find some useful information there….

weird things happening

removed node-red from rc.local now dockerd
it was there because nodered will not start on boot .....

did you cli enabled and then clicked in luci?? that is an on/off switch in luci, you effectively disabled the service when it was enabled.

you should not use rc.local it is not the right place to start services. race condition can happen indeed, you can play with START variable in service file which will set the start order of services.

dockerd was enabled by default after installation, node-red was the issue, now I am searching for a solution to start node-red after boot