SSH still prompting for password for root

In LUCI, I disabled root login with password.

When I am trying to connect from my Linux to Openwrt, over WAN, OpenWRT is still prompting me for password after key files are rejected.

Any hints to fix this?

OpenWRT: Version: Powered by LuCI openwrt-19.07 branch (git-20.057.55219-13dd17f) / OpenWrt 19.07.2 r10947-65030d81f3
sshd: Dropbear ver 2019.78-2

Did you disable Password authentication as well? (the first tickbox in Luci-Administration page SSH Access tab.

1 Like

Thanks for your quick reply!

Password authentication is enabled.

I want to create additional non-root user, and allow password login to non-root users, while restrict root to key login only.

Is that possible?

It should be but it is not common.[]=add&s[]=user#create_a_non-privileged_user_in_openwrt

Thanks for the link.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.