SSH key does not work

I generated my public-private keys on my computer
The public key I generated is as follows
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDTM3281UZhiful8xkk77roOxN1RNHkar+4nneTpJ3PKYUyD8/7sk5cZo7tWAkD6Z7Ot1rvvIDDHr74CSYuPjtzzn0RnGcKMp5ZaxngvuT1wfqPqkBsVV6czS4Gti/UZwWq5ZfmaTy8gFzCvfI5mWWPxF8BUwBmn9c7ek49CXS4tkQrd+UBqA2z9H2JQquCZGm0LeR8mdwbZZP4XsFETf/YttiwdraLli3Btt4767aNbnhY+LgnHWMVw4zWVSNE0v//BJ3qoqcOwmSy3O6For7I1S5/JlYKxMiYRhXxj359sPb60nE6e8Y5pX92U8sr1uv7vQxJrMA114ao5peU0LEZ user@MY-PC

My router uses OpenWrt 18.06. I then log into my router by SSH (still using password) and copy the above public key (beginning with AAAA.. and ending with ..LEZ) to /etc/dropbear/authorized_keys.
Also I am not logging in as root (I have created another user and disabled root access), I had read that I should also create the same file in ~/.ssh/authorized_keys so I did that as well.
All files are chmod 600 and their directories are chmod 700
However I still can't log in with putty, says "server refused our key". Have been struggling with this for so many hours.
Can someone help me troubleshoot this issue?

You should copy the entire line starting with ssh-rsa, not just the key itself.


That was it, thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.