SSH from asterisk dialplan (OWrt 22.03)

Has anyone tried to ssh from the asterisk dialplan to another machine?
I'm trying:
exten => 333,n,System(ssh -i /asterisk/.ssh/id_dropbear hostname5 'whoami > /tmp/SSH-WHOAMI')

In OWrt 18 and asterisk15 all worked. Now asterisk runs from its own user asterisk and all I tried was unsuccessful.

For testing reasons I set all CHMOD to 777 recursively for /asterisk directories and files (keys are located there). No effect.
Whoami from asterisk locally shows asterisk.
Locally asterisk creates (from the dialplan, so it reads and writes) files in /asterisk directory.
Even copied binary dropbear to home folder and changed permissions to 777 as well, to call it from there. No luck.
From console (root) all works.

Is the asterisk user set as allowed user for ssh?

hmmm... Not sure. How do I manage this except by the user permissions?

To confirm the error, bring up asterisk -r in a console. And dial the extension.

The possibility I have on my mind, is here:

Basically add a user for ssh, then dial with that user.