SSH/Dropbear not working on fresh install of OpenWrt 23.05.2

Hi,

I've just installed OpenWrt 23.05.2 r23630-842932a63d on a TP Link Archer C7 v2 machine, using TFTP. After the install I can access the administration panel LuCI with a webbrowser, but I cannot connect using SSH.

My desktop is connected to Archer C7 using UTP To a LAN port of the Archer C7 and receives DHCP:

ipconfig

Ethernet adapter Ethernet 2:

   Connection-specific DNS Suffix  . : lan
   Link-local IPv6 Address . . . . . : fe80::6791:4b3:4a7e:a5a7%26
   IPv4 Address. . . . . . . . . . . : 192.168.1.136
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

If I try to SSH into the OpenWRT I cannot reach port 22:
ssh -v root@196.168.1.1

OpenSSH_for_Windows_8.6p1, LibreSSL 3.4.3
debug1: Authenticator provider $SSH_SK_PROVIDER did not resolve; disabling
debug1: Connecting to 196.168.1.1 [196.168.1.1] port 22.
debug1: connect to address 196.168.1.1 port 22: Connection timed out
ssh: connect to host 196.168.1.1 port 22: Connection timed out

Under LuCI under Status -> Processes, I can see the dropbear process running:

3043	root	/usr/sbin/dropbear -F -P /var/run/dropbear.1.pid -a -p 192.168.1.1:22 -p fd0a:bbc:4217::1:22 -K 300 -T 3	0%	1%

I also see Dropbear is creating warnining messages in the system logs (LuCI Status -> System Log):

Tue Nov 14 13:39:26 2023 authpriv.info dropbear[1638]: Not backgrounding
[snip]
Tue Nov 14 13:43:30 2023 authpriv.info dropbear[1638]: Early exit: Terminated by signal
Tue Nov 14 13:43:30 2023 authpriv.info dropbear[2953]: Not backgrounding

I've tried rebooting the system, restarting the dropbear process (LuCI Status -> Processes), and installing the image a second time, but nothing works.

Do you have any idea how I can solve this issue?

Thanks,
Joost

should be root@192.168.1.1

1 Like

Thanks for your input and well spotted! I tried ssh -v root@196.168.1.1 as well, with the same results.
I'll modify my question based on your feedback, to prevent confusing others.

Please read carefully.

1 Like

I feel really dumb.... Thanks for your patient explanation....
(and the feeling dumb part has nothing to do with you, but all with me...)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.