Ssh connection rejected after failed 19.07.01 upgrade on Netgear R8000

I was running 19.07.0 and tried to do a upgrade to 19.07.1 via the Flash New Firmware Image link. I selected to retain settings and after the router rebooted I was still running 19.07.0. I had a similar problem going from 18.06.4 to 18.06.5 as detailed R8000 won't upgrade from 18.06.4 to 18.06.5.

A helpful forum user suggested that I use SSH to upgrade and that worked previously. Now when I try to connect via SSH I get connection refused. I don't even get the username prompt so it appears like port 22 is closed.

I can login via LuCI and everything appears to be running fine. Will I be able to troubleshoot this via LuCI only and if so, how?

I would create a new instance of dropbear on a different port, allowing password authentication for everyone and see if that change would solve the problem. If not, backup and restore defaults.

trendy, before I saw your response I tried something else. I flashed the 19.07.0 image. Still no SSH. Then I restored my backup config that I took immediately after upgrading and configuring 19.07.0. This step has restored SSH connectivity. My wife is currently trying to get some work done so I have to postpone my next upgrade attempts for a while.

Exactly the same problem here, TP Link TL-WDR4300 upgrading from 18.06.04 to 19.07.01, ssh connection rejected.
Tried to change port, removed my ssh key and tried to use password, no way to use ssh :frowning:

Reverted to 18.06.04, luckily I had a configuration backup.

You should pay more attention before putting a new release in production.

Upgraded to 19.07.2 same problem.

Does not exist yet. And in your case, the problem was likely related to the change in target (ath79 from ar71xx).

It does exist.

19.07.2 was tagged two days ago.;a=shortlog;h=refs/tags/v19.07.2

And it was built by buildbot during the weekend, but it has not been formally released, yet.

1 Like

Thanks @hnyman. My bad :crazy_face: