SQM QoS increases download speed but slows down surfing

This feels to small for typical VPN overhead. With OpenVPN in TCP mode I would expect at least 18+20+20=58 bytes of overhead, and an accordingly smaller MSS... so if you are still in the game please post the results from speedguide.net's TCP analyzer...
The thing is, for a given packetsize you can make up for a wrong overhead by simply reducing the shaper rate, but once small packets are used (like TCP ACKs), bufferbloat will appear again. That is why we typically recommend to mildly overstimate the overhead setting, but the value of 44 will be too small for VPNs or other tunneling encapsulations.

« SpeedGuide.net TCP Analyzer Results »
Tested on: 2021.06.30 17:33
IP address: 128.90.xxx.xxx
Client OS/browser: Mac OS (Safari 605.1.15)

TCP options string: 020404ae010303060101080ab8c113180000000004020000
MSS: 1198
MTU: 1238
TCP Window: 131584 (not multiple of MSS)
RWIN Scaling: 6 bits (2^6=64)
Unscaled RWIN : 2056
Recommended RWINs: 64692, 129384, 258768, 517536, 1035072
BDP limit (200ms): 5263kbps (658KBytes/s)
BDP limit (500ms): 2105kbps (263KBytes/s)
MTU Discovery: ON
TTL: 51
Timestamps: ON
SACKs: ON
IP ToS: 00000000 (0)

I think you were right.

Set the overhead to 58 and the letancy is great now!

Is it possible to set 2 SQM.

One for lan0 and one for tun0?

I am using VPN Policy based routing so I don’t route everything through the tunnel…

You should place a second instance on wan. It might be a bit much CPU overhead with two SQM and a VPN