SQM QoS - eth0 or WAN or?

Hi all,

Router: Linksys E7350
OpenWrt 23.05.3 r23809-234f1a2efa

I've tried to follow the instructions I found in the forum and via some googling but I'm just not sure...

Do I want to enable SQM on eth0 or WAN? I seem to have both interfaces and the info I've found is conflicting.

ifconfig lists the following interfaces:

eth0
ifb4wan
lan1
lan2
lan3
lan4
lo
phy0-ap0
phy1-ap0
wan

if I cat /etc/config/network...

there is no entry for eth0, but there is one for "wan" - so I'm assuming wan?

In status / real-time graphs / traffic - I can see traffic on both eth0 and wan...

i'm so confused. :frowning:

Post the result of waveform test if you have any problem enabling SQM can solve.

If the WAN interface has nothing but eth0 (or any single device) you can use either.

Technically, you are to designate an interface (not a device) but I use eth0 and it works fine.

You can try both and see for yourself it makes a difference. I doubt it will; as long as the shaping is pointed to the incoming traffic.

Now that I think about it WAN could cause problems because it would not include wan6 but eth0 covers both.

Isn't wan6 typically defined as @wan? Anyway easy to test whether ipv6 is exempted from the shaper, just set the shaper rate really low (e.g. 1/10 of the contracted rate) then preform a speedtest over IPv4 and one over IPv6...

Likely both should do. Could you post the output of:
ifstatus wan | grep -e device
please? That should tell us a bit more...

Typically? I don't know.

Thanks, is that the default settings, or did you configure this by hand? Have you tested whether wan/eth0 makes a difference in SQM's settings related to shaping IPv6 traffic?

Straight out of the box.

I disable IPv6, so I don't know.

1 Like

ifstatus wan | grep -e device

    "l3_device": "wan",
    "device": "wan",
1 Like

In this case I would instantiate sqm on the interface named wan....

First do measurements without any QoS
Then check ip link

wan@eth0 -> eth0 is netcard
wan -> wan is the netcard

I have not tried changing the settings to a small value then running a speed test - I'll do that later today and test on using both eth0 and wan.

The feedback so far has been very helpful and much appreciated.

If I'm understanding it correctly, it seems the same traffic goes over eth0, wan, and wan6 with difference being eth0 is the physical device, while wan and wan6 are "interfaces" that use eth0. This makes me think eth0 is the proper configuration choice, but I'll test later to find out.

1 Like
root@OpenWrt:~# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc cake state UP qlen 1000 link/ether xx:xx:xx:xx:cd:06 brd ff:ff:ff:ff:ff:ff
3: wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether xx:xx:xx:xx:91:c5 brd ff:ff:ff:ff:ff:ff
4: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000 link/ether xx:xx:xx:xx:91:c4 brd ff:ff:ff:ff:ff:ff
5: lan3@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000 link/ether xx:xx:xx:xx:91:c4 brd ff:ff:ff:ff:ff:ff
6: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000 link/ether xx:xx:xx:xx:91:c4 brd ff:ff:ff:ff:ff:ff
7: lan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000 link/ether xx:xx:xx:xx:91:c4 brd ff:ff:ff:ff:ff:ff
17: ifb4eth0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc cake state UNKNOWN qlen 32 link/ether xx:xx:xx:xx:83:8a brd ff:ff:ff:ff:ff:ff
19: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000 link/ether xx:xx:xx:xx:91:c4 brd ff:ff:ff:ff:ff:ff
20: phy0-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000 link/ether xx:xx:xx:xx:91:c6 brd ff:ff:ff:ff:ff:ff
21: phy1-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000 link/ether xx:xx:xx:xx:91:c7 brd ff:ff:ff:ff:ff:ff
1 Like

wan is internet connection. Start with that IF you have any indications of bufferbloat (or dont touch anything if not)