SQM Performance issues with TP-Link C2600


I upgraded my Internet connection up to 250/20 Mb/s. I needed a more powerful router to handle it with SQM. The Netgear R7800 is quite expensive and I could get TP-Link C2600 40% cheaper then the competitors. So I bought it.

I configured it and I'm not very happy with SQM performance. I can get something around 160-180 Mb/s with SQM. That's not quite what I expected. The CPU is not the issue. There's plenty of power left.

I also tried the yesterday snapshot with the same config and the performance was terrible. Compered to the stable it's a disaster. The whole console was lagging as hell. I don't know what's the issue. I heard that Netgear R7800 (same platform) has issues with SQM. Can someone tell me more about it?


My SQM config:

config queue 'eth0'
	option enabled '1'
	option interface 'eth0'
	option download '237500'
	option upload '19000'
	option debug_logging '0'
	option verbosity '5'
	option qdisc 'cake'
	option script 'layer_cake.qos'
	option qdisc_advanced '1'
	option squash_dscp '1'
	option squash_ingress '1'
	option ingress_ecn 'ECN'
	option egress_ecn 'NOECN'
	option qdisc_really_really_advanced '1'
	option iqdisc_opts 'nat dual-dsthost diffserv4 rtt 300ms mpu 64'
	option eqdisc_opts 'nat dual-srchost diffserv4 rtt 300ms mpu 64'
	option linklayer 'ethernet'
	option overhead '18'
	option linklayer_advanced '1'
	option tcMTU '2047'
	option tcTSIZE '128'
	option tcMPU '64'
	option linklayer_adaptation_mechanism 'cake'

It seems the Problem is still not fixed. I have the same issue. The performance with layer cake its terrible. I have opend a issue under FS#1832.

considering the changes in cake since OP's post, i doubt this is the "same issue" and thus this to be kinda necro.

apart from that

  • please look at the idle % and sirq % in top while testing. i doubt the device has "plenty of power left"
  • rtt 300ms sounds a bit high, how is it doing with default (100ms)?
  • the bugreport mentions a big difference in layered/piece_of_cake, sounds worthy of further investigation
  • i guess your connection is (tv-)cable which is somewhat antagonistic in nature to the effects of sqm

@dtaht @moeller0 any thoughts?

A bit more information like "cat /etc/config/sqm", "tc -s qdisc", a link to a dslreports speedtest might help to make more sense out of the observation that the router does not perform as well as expected with sqm.
I also note that on r7800 people had to do quite some debugging to make it work, IIRC the issues where with power save modes of the CPU and CPU affinity, and some snmp issues related to querying counters of the switch chip (I am a bit unsure about the last one). Assuming the c2600 uses a similar SoC, maybe not all fixes have been transferred to that device yet?

3 posts were split to a new topic: Archer 2600 - sqm, issues on Telekom VDSL2