Sqm for wrt3200 on a 200\100 FTTH

Hello i have a fiber internet with no ppoe protocolo only vlan 100 to have internet, voip and iptv .

What will be a good sqm config for my connection im dummy with IT :sweat_smile:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fddc:2df2:c8ca::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth1.100'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'eth1.100'
	option reqaddress 'try'
	option reqprefix 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 5t'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4t 6t'
	option vid '100'
	option description 'Internet'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '101'
	option description 'Voip'
	option ports '1 4t'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '105'
	option description 'Iptv'
	option ports '0 4t'
config queue 'eth1'
	option enabled '1'
	option interface 'eth1.100'
	option download '184000'
	option upload '85000'
	option debug_logging '0'
	option verbosity '5'
	option qdisc 'cake'
	option qdisc_advanced '1'
	option squash_dscp '1'
	option squash_ingress '1'
	option ingress_ecn 'ECN'
	option egress_ecn 'NOECN'
	option linklayer 'ethernet'
	option script 'piece_of_cake.qos'
	option qdisc_really_really_advanced '1'
	option eqdisc_opts 'nat dual-srchost mpu 64'
	option overhead '35'
	option iqdisc_opts 'nat dual-dsthost ingress mpu 64'

With some healp of @moeller0 i change the mpu to 73

The /etc/config/sqm looks sane. Overhead for fiber is really really hard to figure out, but 35 should be in the right ball park, for all I know.
mpu 64, not sure I would naively guess for GPON with VLAN this should be 73 and for active ethernet with a VLAN tag probably 88.

Now i have this:

config queue 'eth1'
	option enabled '1'
	option interface 'eth1.100'
	option download '184000'
	option upload '85000'
	option debug_logging '0'
	option verbosity '5'
	option qdisc 'cake'
	option qdisc_advanced '1'
	option squash_dscp '1'
	option squash_ingress '1'
	option ingress_ecn 'ECN'
	option egress_ecn 'NOECN'
	option linklayer 'ethernet'
	option script 'piece_of_cake.qos'
	option qdisc_really_really_advanced '1'
	option overhead '35'
	option eqdisc_opts 'nat dual-srchost'
	option linklayer_advanced '1'
	option tcMTU '2047'
	option tcTSIZE '128'
	option tcMPU '73'
	option iqdisc_opts 'nat dual-dsthost ingress'
	option linklayer_adaptation_mechanism 'default'

Any change that i have to do

In the end the real question is how well does it perform. This looks like a sane baseline. But how well do games play? How does dslreports.com speed test work?

Like this

Some diference in down and up to the sqm rate limits

Those look excellent, so stick with it.

And what about my speeds, its normal

In my last sqm config i have mpu 64 now i have 73

Just use it for a while, see how reliably it works. Getting every little bit of speed out of your connection is kinda pointless, but trying to get very low latency is worthwhile if you game or use VOIP or do video calls. You have excellent latency here, so just use it.

the shaper rate is the gross interface rate, with these setting you can at best expect the following TCP/IPv4 goodput (what typical speedtests measure) of:

184000 * ((1500-20-20)/(1500+35)) = 175009.77 Mbps
85000 * ((1500-20-20)/(1500+35)) = 80846.91 Mbps

as you can see in the upload direction your tests are already close to the theoretical maximum. Sure the downloads seem to under perform a bit, that might (or might not) be related to the CPUs in your router which might be overloaded or might try to use powersave features which interact badly with SQM, you could try the performance governor.

This just tells SQM what the smallest on-the-wire size of a packet actually is. During speedtests almost all packets are at maximal size, and hence the MPU setting will not affect normal uni-directional speedtests at all.

1 Like

A week ago i have that speeds on the speed test, its seens any kind of problem with my isp

Well, if you disable SQM and repeat the speedtest, and the results stay low, that would indicate that SQM is not the root cause.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.