SQM and Whatsapp calls

When I activate SQM my Whatsapp calls keep dropping every couple of minutes.
Disabling SQM seems to solve the problem.
I'm using OpenWrt 19.07.5 on a TP-Link Archer C60 v2
I have 150 mb up\down but limited to 100mb because of the ports.

Do you have sqm over wan interface?
what are sqm settings?

Yes

Queuing discipline: Cake
Queue setup script: piece_of_cake.qos
Download speed (kbit/s): 95000
Upload speed (kbit/s): 95000

Show all settings sqm with:

cat /etc/config/sqm

I recommend you this settings.

Config queue 'eth0'
        option enabled '1'
        option interface 'eth0'
        option download '95000'
        option upload '95000'
        option qdisc 'cake'
        option script 'layer_cake.qos'
        option ingress_ecn 'ECN'
        option egress_ecn 'ECN'
        option itarget 'default'
        option etarget 'default'
        option linklayer 'ethernet'
        option overhead '44'
        option tcMTU '1544'
        option tcMPU '64'
        option iqdisc_opts 'diffserv4 ingress dual-dsthost'
        option eqdisc_opts 'diffserv4 dual-srchost'

I thought the script should be layer_cake.qos when using diffserv?

1 Like
config queue 'eth1'
        option interface 'eth1'
        option debug_logging '0'
        option verbosity '5'
        option qdisc 'cake'
        option script 'piece_of_cake.qos'
        option linklayer 'ethernet'
        option overhead '44'
        option download '95000'
        option upload '95000'
        option enabled '1'
        option qdisc_advanced '1'
        option squash_dscp '1'
        option squash_ingress '1'
        option ingress_ecn 'ECN'
        option egress_ecn 'ECN'
        option qdisc_really_really_advanced '1'
        option iqdisc_opts 'diffserv4 ingress dual-dsthost'
        option eqdisc_opts 'diffserv4 dual-srchost'
        option linklayer_advanced '1'
        option tcMTU '1544'
        option linklayer_adaptation_mechanism 'default'
        option tcMPU '64'

I use luci. Do I have to unselect the advanced options?

I forgot that the nat option is required.

        option iqdisc_opts 'diffserv4 ingress nat dual-dsthost'
        option eqdisc_opts 'diffserv4 nat dual-srchost'

Added the nat option. Will this affect my ping in games?

I don't know if this is correct but I think it forces to use 4 priority queues (diffserv4): Bulk, BestEffort, Video, Voice.

piece_of_cake.qos I think it uses only BestEffort .

No, if CAKE is running on the device performing IPv4 NAT then it can look into the device's NAT tables to determine the internal addresses and then base the fairness on that. Unfortunately it's not the default, so we have to specify it.
https://openwrt.org/docs/guide-user/network/traffic-shaping/sqm-details#more_hints_tips_info

1 Like