Splitting main switch into two subnets with dhcp

Hi,
I've got all my usual ethernet equipment on three of the four internal sockets(lan,192.168.1.0/24,dhcp) , but want to split the fourth off to create a subnet of 192.168.3.0/24, where both subnets can communicate freely but get given different network addresses. 192.168.2.0/24 is a dmz on wireless, which uses firewall rules to get to the wan.The motivation for this is that I've a machine which has a fast wireless card and a slow (powerline) ethernet. I want to have the speed of the wireless on 192.168.1.x but I want to create a bridge for KVM virtual machines, which can't done over wireless, so those machines have dhcp assigned addresses and DNS. The first step was to move the powerline port onto it's own VLAN and mark than port as untagged and the internal eth1 as tagged, then I created a static interface with address 192.168.3.1, subnet mask 255.255.255.0, and broadcast 192.168.3.255, and bridged it to all the other internal interfaces and wlan1. I added this interface to the lan, but when I connect I only get a 192.168.1.2 address. I think I'm using the right port as it changes from 100BaseT to no link when I pull the cable out. Here's my settings for network and dhcp.

 cat dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/xyz.com/'
        option domain 'xyz.com'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        list server '8.8.8.8'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'dmz'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'dmz'

config host
        option name 'www'
        option dns '1'
        option mac 'B8:27:EB:F6:A9:40'
        option ip '192.168.2.241'

config host
        option name 'nextcloud.hawaiian'
        option dns '1'
        option ip '192.168.1.173'

config dhcp 'VirtualMachine'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'VirtualMachine'
        option force '1'


 cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde6:4511:0f54::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth1.1 eth1.3'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '6t 4 3 2'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'
        option vid '2'

config interface 'dmz'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option broadcast '192.168.2.255'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '6t 1'

config interface 'VirtualMachine'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.3.1'
        option broadcast '192.168.3.255'
        option type 'bridge'
        option ifname 'eth1.1 eth1.3'
uci set network.lan.ifname="eth1.1"
uci set network.VirtualMachine.ifname="eth1.3"
uci commit network
/etc/init.d/network restart

Sorry, that didn't work, still get the same 192.168.1.2 ip address, but with no connectivity. Am I going to manually open a connection between the two subnets in the firewall for DHCP?

Should I put this new interface in it's own firewall zone, and use firewall rules to move the data from subnet to subnet? Adding this interface to the existing zone didn't help.