Speed on R7800 suddenly drops to 100mbits

Hi I've got a weird one. I've been running openwrt (4.14.215) successfully on my R7800 for at least 6 months now. But once in a while, my internet speed keeps dropping to around 90Mbits/down. My speed is always 200Mbits/down.
(Btw, I use my R7800 as an access point so the connection comes into one of my LAN ports.)

So when that happens I look into my switch tab and see that my LAN port changed to 100baseT
full-duplex instead of gigabit.
I disconnect the cable, and reconnect it back and boom I have gigabit again. This happened again yesterday evening, fixed the issue by doing to above. And this morning it's back to 100Mbits.

The cable I use is a long one, pretty old (but has always worked) and doesn't have any sharp bends in it. From everything I see online it might just be a faulty cable. Could this be the case perhaps? I find it weird that this just suddenly happens even tho I didn't move the cable whatsoever.

Nothing in dmesg?

Tried forcing the speed using ethtool?

How long is the cable? Any sources of rf nearby?