Speed Fluctuation Problem!

Hello. I am using Xiaomi 4A Gigabit Edition, my openwrt version is 22.03.5. I have an intel centrino n6235 wi-fi card in my laptop (with 5G + 2.4Ghz features). I do not have any problems with the speed test on my mobile phones, but when I test the speed on my laptop, I experience extreme fluctuations and my download speed decreases very much. I do not have any problems when using the stock ROM or my other device, TP-Link. However, whenever I install OpenWrt on my router, I start having problems with my speed. I added the images in the subject attachment. I'll be happy if you can help me...



First course of action, open three ssh sessions to your router, one running htop (installable package), the second running logread ; logread -f and the last one running hostapd_cli -i <interface_name_of_your connected_WLAN (packaged in hostapd-utils), then do your (multiple) tests again - check for cores running out of steam, error messages in the logs, channel switches, disconnects etc.; bonus points for running equivalent checks (akin to wpa_cli) on the affected client as well.

Maybe the above already provides pointers, but for meaningful results you probably will have to disentangle "internet connectivity" and "WLAN/ AP usage", by using a local packet source for your testing (e.g. iperf3 through the AP, not running on top of it).

2 Likes

i did all tests...the problem continues
htop screen;




and others screens;


I think my processor usage is increasing

my internet connection is FTTH fiber 100mbps.

any help :frowning:

i will return stock rom..

Might be a long shot but are all devices you are testing connecting to the same wireless interface (e.g. 2.4GHz or 5GHz)? If there is a difference in channels between TP Link stock firmware and OpenWRT then you might be getting some interference.

No. Some of the devices at home use 2G and some use 5G...

I am not currently using my TP-Link device, TP-Link is turned off. I use my TP-Link device occasionally for testing.

Have you tried changing some of the radio settings in OpenWRT (change channels, widths, power etc)?
Maybe disable one of the wifi interfaces and just test it on different channel with your laptop.

Can also try a channel analysis...

yes I tried them all. In the channel analysis, the result is 100%, so there is no problem.

Could it be causing problems with IPv6 settings or Wi-Fi security settings? (my laptop's wifi card is Intel N6235, produced in 2013, supports 5G and 2G)

Could be, it is worth trying different encryption /ipv6 settings (trying anything is preferable to trying nothing :slight_smile: ).
The vintage of your laptop wifi could be an issue, but if it works OK with other routers then I would suspect there is some kind of quirk with Openwrt which the laptop wifi card does not handle well.

I noticed in your logs that you are getting de-auths due to inactivity for multiple MACs.
Do you know what is causing that?
If not maybe try some of the fixes mentioned in this post (not exactly the same Mediatek chip or OWRT version, but might have common driver)?

While doing the tests in the images, I disconnected the other wireless devices in the house. Also, I only experience this problem on my Xiaomi 4A Gigabit Edition with OpenWrt installed. I went back to the stock rom last night and there are no problems... no speed fluctuation or crashing.. I will try the articles in the link.

note: Deauthentication of clients due to inactivity - Installing and Using OpenWrt - OpenWrt Forum -> everyone is having the same problem. There is no problem with older versions (I heard that the stock rom is openwrt v19 version)

It is considered rather rude, to cross-post a topic. This is a foeum (not google, where you need to use SEO or link farm tactics)
You have your main thread (this one) and you have responses. But there will not be better solutions or more solutions by demanding a solution in even more threads.

your cross posts so far in the last few hours:

1 Like

whats is your problem bro ?

@Pico - thanks for making note the OP has posted in numerous threads.

1 Like

is there a any solution for my problem!