Specific speeds on each lan port

Hi, im new here just wanted to know if this is possible.

I have a openwrt router and i wanted to have specific speeds on each lan port

lan 1 = 11mbps up and 11mbps down
lan 2 = 3.33mbps up and 6.66mbps down
lan 3 = 2.5mbps up and 5mbps down
lan 4 = 33.3mbps up and 66mbps down

are these possible?

thanks for the future replies.

@sgt_trigger17, welcome to the community!

I would just use plain QoS to configure that on the LANs.


Installing luci-app-qos should obtain all needed packages, and a menu item will appear at Network > QoS.

Hi @lleachii ,

I managed to add QoS on my openwrt, However I cannot add classification groups it is always saying on "default"

I Have already set my 4 connections to static addresses. on DHCP Leases.

Hostname	IPv4-Address	MAC-Address	Leasetime remaining
test1	xx:xx:xx:xx:xx:xx	11h 59m 59s
test2	xx:xx:xx:xx:xx:xx	11h 59m 59s
test3	xx:xx:xx:xx:xx:xx	11h 59m 59s
test4	xx:xx:xx:xx:xx:xx	11h 59m 59s


any suggestions?

  • You never provided the config
  • I'm not sure what you mean by "adding classification groups," or rather why you're trying to do that
  • You simply need to create a QoS queue for each interface and specify the speed

SQM works by interfaces not IP addresses. So first you'd have to have separate interfaces for each port. On a device with a switch create a separate VLAN in the switch for each port then software bridge them back into the LAN network. Exactly how to do this depends on the hardware model.

Then you can set a QOS instance on each one, e.g. eth0.3 would be port 3.

1 Like

router model: D-Link DIR-610 A1

firmware version: LEDE Reboot 17.01.0 r3205-59508e3 / LuCI lede-17.01 branch (git-17.051.53299-a100738)

kernel version: 4.4.50

I tried by adding switch and adding interface and bridge but the problem is it cannot go to the internet.

You can do micromanagement on the bandwidth allocated to each device with luci-app-nft-qos
So if you keep the same devices connected to each port, you can configure it with that tool.

1 Like

I cannot find that package on my router.

Output of: ubus call system board ?

sorry I don't understand. What do you mean by that?

I mean to run the command and paste here the output.

1 Like

I'm using the LEDE-LuCi UI. where do I type in that command?

Use ssh to connect to the device and run the command. Then copy-paste the output here.

1 Like
root@LEDE:~# ubus call system board
        "kernel": "4.4.50",
        "hostname": "LEDE",
        "system": "Ralink RT5350 id:1 rev:3",
        "model": "D-Link DIR-610 A1",
        "release": {
                "distribution": "LEDE",
                "version": "17.01.0",
                "revision": "r3205-59508e3",
                "codename": "reboot",
                "target": "ramips\/rt305x",
                "description": "LEDE Reboot 17.01.0 r3205-59508e3"

Very weak device with 4MB flash and 32MB Ram.

Old and unsupported version.

Package was introduced in 19.07 version, so I am afraid you cannot use it with this router.

1 Like

Sad to hear that, Can i use the workaround version posted above then?

But the problem is I am stuck on switch and interfaces...

this workaround will do I tried it but It doesn't allow me to connect to the internet. (replied with screenshots above)

Your test interface doesn't seem to be in a firewall zone allowed to send traffic to WAN. Simply add it to LAN firewall zone and inform us of the results.

It also appears to not be setup with IPs, etc. I would say use the LAN network and DHCP rules as your guides...you can look from the web GUI, but you can also copy/paste from command line.

  • Make static
  • Assign IP
  • Enable DHCP

What @trendy said that is an old, not powerful CPU and operation at 66 Mb is likely not possible. If your Internet service is faster than about 20 Mb you really need a new router.

In the switch, create three new VLANs. The LAN VLANs could be 1 (existing), 3, 4, and 5, since 2 is the WAN. Set the CPU port "tagged" in every VLAN. Set each of the LAN ports "untagged" in its one VLAN, and "off" in all others. Go to the lan physical settings and add eth0.3 eth0.4, and eth0.5 to the bridge.