Specific DNS for individual host applies to all hosts (child internet filtering setup help)

hello all,

we are currently enforcing a break from certain websites for one of our children, so i have configured openwrt to use opendns (with some filters enabled on opendns) so that these websites are blocked, but only for this child's computer. (and yes, i know kids are smart and this block was done with the child's agreement and to cut down a compulsive use of social media)

what is bothering me is that somewhat randomly, other computers in my network are using opendns as well (all other clients should use google or cloudflare dns). openwrt will seem to use opendns for a few minutes on another device and then it will start to use the correct (non-restricted) DNS again. afaik, the child's device is consistently using opendns - so that part works. just the somewhat annoying blocking of my computer (haha, a taste of your own medicine old man, yes, yes..)

is this a configuration issue or perhaps a bug? are there better ways to do this (i did consider just setting the DNS on the child's laptop, or simply blocking with /etc/hosts - the kid runs ubuntu on a chromebook )

below is what my configuration looks like (some details hidden <name of what was hidden>)

any ideas or help appreciated


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option rebind_protection '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

# this is the opendns configuration - specified via a tag

config tag 'opendns_tag'
	option dhcp_option '6,,'

# child computer configuration - with `option tag 'opendns_tag'`

config host
	option name 'child_computer'
	option mac '<child mac address>'
	option ip ''
	option tag 'opendns_tag'
	option duid '<duid_goes_here_duid_goes_here_duid>'

# there are some other configs like this

config domain
	option name 'othercomputer'
	option ip ''

# and also some config like

config host
	option dns '1'
	option duid '<DUID_HERE>'
	option name 'anothermachine'
	option mac '<MAC_HERE>'
	option ip ''

ok, i feel a bit stupid. i turned on dnsmasq logging and looked at what servers it was using. even though openwrt was using google/cloudflare dns, my cable modem was using opendns!

so that explains it. doh. i will remove opendns from the cablemodem.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.