Source Code 19.07.1

HI, I tryed to download a new source code 19.07.1 using:

git clone


git clone

but after downloaded and compiled, firmware is always snapshot (), why?

I have to wrong url download?

ths Gianluca

You need to checkout the release ...

After cloning the repo, fetch the tags and checkout the correct one:

git fetch --tags
git checkout v19.07.1

Hi, below responce command:

**> $git fetch --tags**
*remote: Enumerating objects: 154, done.*
*remote: Counting objects: 100% (148/148), done.*
*remote: Compressing objects: 100% (75/75), done.*
*remote: Total 80 (delta 58), reused 3 (delta 3)*
*Unpacking objects: 100% (80/80), done.*
*   39a49c2..be3e98c  master     -> origin/master*
*   b6c01fe..95d5cbd  openwrt-19.07 -> origin/openwrt-19.07*

**>$ git checkout v19.07.1**
*Note: checking out 'v19.07.1'.*

*You are in 'detached HEAD' state. You can look around, make experimental*
*changes and commit them, and you can discard any commits you make in this*
*state without impacting any branches by performing another checkout.*

*If you want to create a new branch to retain commits you create, you may*
*do so (now or later) by using -b with the checkout command again. Example:*

*  git checkout -b new_branch_name*

*HEAD si trova ora a 901bbe2... OpenWrt v19.07.1: adjust config defaults*

now i'm compileing and check if now is ok


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.