SOS, Help. My E3000 down after flashing 17.01.1

Hi, good day, everyone
I am new to this forum just after installing lede-17.01.1-brcm47xx-generic-linksys-e3000-v1-squashfs on my E3000 from factory firmware. But unfortunately after reboot, it never stops rebooting nor of course can access to the router again. Does anyone know and how to get it work? Thx.

My asus router had a specific sequence that could be done to do a clean wipe to factory settings that was firmware-agnostic that resulted in being able to use a windows app to connect and flash a new firmware. I would bet your router has a similar functionality.

"Reset - There are two (2) ways to reset the router to its factory defaults. You can either press and hold the Reset button for 10 seconds, or restore the defaults from the Administration > Factory Defaults page on the router's web-based setup page. To know more about resetting your device, click here."

Also, this thread:

I had issues flashing Lede from stock fw on my E2000. I ended up flashing via TFTP instead to get it to work. Your bootloader should still be functional, so TFTP is still an option. See the notes section here:

Thanks. But didn't work though the command window told the "firmware was successfully uploaded. It took 3 seconds". Then nothing happened. Pings to the router was ok. Opening the router in the browser failed.

I have tried all your ways. None of them worked. Now my E3000

  1. can be pinged;
  2. can be upgraded/uploaded with firmware via tftp; (seems not flashed/upgraded)
  3. its lan port in use blinks;
  4. but can't be reached in the browser

One more question. do I have to install "factory installation" first on stock firmware before the upgrade one? But i found no such installation for e3000

I bricked an E3000 recently and couldn't get it to recover via TFTP no matter what I did. But since If figured it was otherwise trash, I tried something I wouldn't normally recommend -- the pin-shorting method here. It worked for me and I was able to recover via TFTP to a working firmware version again (I think I flashed the stock firmware and then to LEDE).

To be clear -- this should be a last resort method since if you do it wrong, you will irreparably damage the hardware. But when all else fails...

Good luck.

Thanks. The last way to take after all others ended. Awaiting the screw driver to arrive and to strip it.

@psherman. Tried today. The power led blinked. The Lan port led lighted. Uploading firmware succeeded. Waited and waited, but still nothing happened. Ping ttl-100. Connection failed. Another problem: except openwrt firmware, the lede one and stock one stopped in the middle of uploading. Using Windows 10 tftp can successfully upload the stock firmware, which didn't work either.

@francishefeng - hmmm... How long did you wait before trying to power cycle?

I used a Mac with the native tftp client and it went without much difficulty. It is important to make sure you are sending in binary mode. I set my Mac to static IP (subnet, gateway I launched TFTP, and got everything ready:

put firmware_filename

I had another window open with a continuous ping running (ping I was ready for the ttl=100 responses right after the pin-short, and immediately hit return on the tftp put command as soon as the ping responses started. I recall being able to see the LAN LED flashing rapidly during this process, making it pretty clear the firmware was being sent to the router (as compared to the ping blinks that happen every 1 second). The firmware transfer completed without error, but then it was a long time (maybe 5 mins or so) before anything else happened.... IIRC, after a fairly lengthy wait, it self-rebooted and started responding to pings. I set my system back to DHCP and got an IP from the router and everything was fine again. It is possible that I did have to power cycle before seeing results, but if so, it was after a long wait after the tftp transfer had finished.

I'd recommend trying again (carefully, of course). You might try a different TFTP program or another host system (i.e. mac or linux) if you continue to have issues with it failing halfway through.

Also, there are apparently pads on the back side of the board for serial. You would have to solder wires to it, but you could try the serial port method of recovery -- if uboot is working, you should be able to get it to pull firmware from a tftp server.

Thanks. I too pushed the firmware via native tftp client in Windows 10. The return in the command window told upload of the firmware was successful. But no reboot even after more than 10 min. Comparing with yours, I found the spec on the memory chip was different from yours though the size looked the same. Don't know if it makes trouble.

@francishefeng - so after 10 mins, I assume you tried a power cycle and the situation did not improve (i.e. the router did not boot and would not respond to pings)? Sadly, I'm out of ideas at this point, aside from recommending you try the serial port connections and CFE recovery process (you'll need to solder wires to the pads on the underside of the board, and you'll likely need to pair that with a USB to serial adapter).

BTW, the photos and process from the link that I shared were not mine (I had found that particular post when my unit was bricked). I didn't pay attention to the markings on the memory chip in my unit. But that said, there is only one version of the E3000, so I would suspect that they may have multi-sourced certain components like the memory, but it should electrically the same.

@psherman. Just finished trying. Nothing improved. The command window still told upload successful, no reboot, the power led still blinking, the lan port led still flashing. Nothing happened. Already ordered usb/ttl cable.

Same thing heppened to me with E1000 V2, no way by traditional methods. At the end, I opened the case and did it by serial soldering four pins to the PCB. Very quick.

I know that you may have tried everything, but if you didn't try it here's another method:

I don't know if this utility does something more that regular TFTP thought...